Hypercell ein ] Hypercell aus ] Zeige Navigation ] Verstecke Navigation ]
c++.net  
   

Die mobilen Seiten von c++.net:
https://m.c-plusplus.net

  
C++ Forum :: Spiele-/Grafikprogrammierung ::  SDL Audio abspielen läuft, aber es kommt kein Ton     Zeige alle Beiträge auf einer Seite Auf Beitrag antworten
Autor Nachricht
HarteWare
Mitglied

Benutzerprofil
Anmeldungsdatum: 16.02.2013
Beiträge: 481
Beitrag HarteWare Mitglied 20:55:48 16.02.2018   Titel:   SDL Audio abspielen läuft, aber es kommt kein Ton            Zitieren

Hallo,

ich versuche via SDL eine .wav Datei abzuspielen. Ich bin dabei folgendermaßen vorgeganen:
C++:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
int err_main(std::string_view msg)
{
    std::cerr << msg << '\n';
    return -1;
}
 
struct AudioData {
    Uint8* pos;
    Uint32 len;
};
 
void MyAudioCallback(void* userdata, Uint8* stream, int streamLen)
{
    auto audio = reinterpret_cast<AudioData*>(userdata);
    if (!audio->len) return;
 
    auto len = std::min(static_cast<Uint32>(streamLen), audio->len);
    SDL_memcpy(stream, audio->pos, len);
 
    audio->pos += len;
    audio->len -= len;
}
 
int main(int argc, char** argv)
{
    SDL_Init(SDL_INIT_AUDIO);
    const char* path{ "testClip.wav" };
 
    SDL_AudioSpec wavSpec;
    Uint8* wavStart;
    Uint32 wavLen;
    if (!SDL_LoadWAV(path, &wavSpec, &wavStart, &wavLen))
        return err_main("Unable to load audio");
 
    AudioData audio{ wavStart, wavLen };
    wavSpec.callback = MyAudioCallback;
    wavSpec.userdata = &audio;
 
    auto device = SDL_OpenAudioDevice(nullptr, 0, &wavSpec, nullptr, SDL_AUDIO_ALLOW_ANY_CHANGE);
 
    if (!device)
        return err_main("Error opening audio device");
 
    SDL_PauseAudioDevice(device, 0);
    while (audio.len > 0)
        SDL_Delay(100);
 
    SDL_CloseAudioDevice(device);
    SDL_FreeWAV(wavStart);
    SDL_Quit();
    return 0;
}


Wenn ich einfach SDL_OpenAudio (ohne -Device) verwende wird die Datei abgespielt:
C++:
SDL_OpenAudio(&wavSpec, nullptr);
SDL_PauseAudio(0);


Hat jemand eine Idee, warum das Programm zwar die Datei abspielen zu scheint, jedoch nichts aus meinem Lautsprecher kommt? Mit Kopfhörern habe ich es auch schon versucht.


LG
C++ Forum :: Spiele-/Grafikprogrammierung ::  SDL Audio abspielen läuft, aber es kommt kein Ton   Auf Beitrag antworten

Zeige alle Beiträge auf einer Seite




Nächstes Thema anzeigen
Vorheriges Thema anzeigen
Sie können Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht mitmachen.

Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme

c++.net ist Teilnehmer des Partnerprogramms von Amazon Europe S.à.r.l. und Partner des Werbeprogramms, das zur Bereitstellung eines Mediums für Websites konzipiert wurde, mittels dessen durch die Platzierung von Werbeanzeigen und Links zu amazon.de Werbekostenerstattung verdient werden kann.

Die Vervielfältigung der auf den Seiten www.c-plusplus.de, www.c-plusplus.info und www.c-plusplus.net enthaltenen Informationen ohne eine schriftliche Genehmigung des Seitenbetreibers ist untersagt (vgl. §4 Urheberrechtsgesetz). Die Nutzung und Änderung der vorgestellten Strukturen und Verfahren in privaten und kommerziellen Softwareanwendungen ist ausdrücklich erlaubt, soweit keine Rechte Dritter verletzt werden. Der Seitenbetreiber übernimmt keine Gewähr für die Funktion einzelner Beiträge oder Programmfragmente, insbesondere übernimmt er keine Haftung für eventuelle aus dem Gebrauch entstehenden Folgeschäden.