GTKmm Tutorial Teil 1



  • vielen dank für die beschreibung,
    ich habe das allerdings genau so versucht, aber in meiner Projektauswahl kann ich nicht Gtkmm Applikation anwählen (auch nicht wenn ich scrolle;)).
    Ich habe Dev-C++ schon installiert gehabt, Version 4.9.8.0, und die liegt bei mir im Verzeichnis C:\Programme\Dev-Cpp, vielleicht hängt das damit zusammen?

    vielleicht habe ich auch einen anderen fehler...
    mein bs: windows xp, ist wohl ok...
    mein compiler: gcc version 3.4.2 (mingw-special), läuft ohne probleme
    mein gtk-installer: gtk-win32-devel-2.8.6-rc3.exe
    mein gtkmm-installer: gtkmm-devel-2.6.2-1.exe

    vielleicht vertragen sich ja die versionen von gtk und gtkmm nicht, habe allerdings nichts dazu gefunden...
    gtk-demo.exe und gtkmm-demo.exe laufen, dann müsste doch eigentlich bei der installation alles glatt gelaufen sein.
    mit pkg-config.exe(?) habe ich nichts konfiguriert, ich denke die kann ich so lassen, da doch alle librarys die ich für meine gtkmm-anwendung benötige von deinem installer über dev-c++ angesprochen werden.



  • Wohin hast du DevC++ installiert?



  • Installationsverzeichnis ist C:\Programme\Dev-Cpp



  • Und steht das bei dir auch in dem Reigstry?

    HKEY_LOCAL_MACHINE\SOFTWARE\Dev-C++\Install_Dir



  • ah ok, habe keinen eintrag in der registry



  • linlinlin schrieb:

    ah ok, habe keinen eintrag in der registry

    Normalerweise sollte das DevC++ bei der installation machen.



  • 1000 dank schon mal für den support.
    habe jetzt den neuen Dev-C++ installiert.
    super sache mit deinem installer, der automatisch generierte code lässt sich kompilieren :), aber leider nicht ausführen 😡 .
    Die Fehlermaldung sagt, dass der Prozedureinstiegspunkt libconv_set_relocation_prefix in der iconv.dll nicht gefunden wurde.
    Kannst du damit was anfangen?



  • ok, ich habe nachgelesen, dass dies passieren kann wenn man mehrere (unterschiedliche) versionen der gleichen dll's auf dem rechner hat, und wenn mit der einen compiliert wird und die andere aufgerufen wird bei der programmausführung - shit...
    habe also eine dll umbenannt, und es folgt eine andere fehlermeldung, toll!

    keine ahnung was ich jetzt tun soll, alles nochmal deinstallieren und neu installieren, habe allerdings auch eine laufende c++ eclipse umgebung die ich eigentlich nicht zerstören wollte weil das mühsam war die zum laufen zu bekommen.... 😕



  • linlinlin schrieb:

    ok, ich habe nachgelesen, dass dies passieren kann wenn man mehrere (unterschiedliche) versionen der gleichen dll's auf dem rechner hat, und wenn mit der einen compiliert wird und die andere aufgerufen wird bei der programmausführung - shit...
    habe also eine dll umbenannt, und es folgt eine andere fehlermeldung, toll!

    keine ahnung was ich jetzt tun soll, alles nochmal deinstallieren und neu installieren, habe allerdings auch eine laufende c++ eclipse umgebung die ich eigentlich nicht zerstören wollte weil das mühsam war die zum laufen zu bekommen.... 😕

    Eine möglichkeite wäre es sämtlich GTK+ Programme und libraries zu deinstallieren und neu zu installieren
    Und ein Reboot wäre auch gut dazwischen ( zwischen deinstall und install )

    😉

    Achja und du solltest die Development libs vorher installieren.



  • 🙂 1000 dank evilissimo, es funktioniert jetzt alles!! 🙂

    falls jemand ähnliche probleme hat, hier meine anleitung was ich gemacht habe.
    1. alles was mit c++ zu tun hat deinstalliert
    2. minGW + msys installiert als compiler umgebung für c/c++
    3. gtk-win32-devel-2.6.10-rc1.exe installiert
    4. gtkmm-devel-2.6.2-1.exe installiert
    5. devcpp-4.9.9.2_nomingw_setup.exe installiert
    dann konnte ich den installer von evilissimo benutzen und alles läuft.
    vorsicht manche versionen von gtk und gtkmm vertragen sich nicht.

    hilfreich fand ich u.a. folgenden artikel:
    http://www.gtkmm.org/docs/gtkmm-2.4/docs/tutorial/html/ape.html

    freue mich jetzt auf deinen 2ten teil vom tutorial.

    Falls jemand eine Möglichkeit kennt wie ich Eclipse konfigurieren kann,
    um gtkmm-projekte zu kompilieren wäre ich sehr dankbar, das hier zu posten bzw zu linken. Selber habe ich da noch nix gefunden...

    gruss + nochmals danke, lin



  • Toller Artikel! Du bist auf dem besten Weg, mich endlich von MFC wegzubringen 😛 *aufatem*.



  • Habe dein Tutorial auch gemacht und würde mich sehr über einen 2. Teil freuen 🙂



  • Das erste GTKmm Tutorial steht jetzt auch als PDF zum Download bereit.

    GTKmm Tutorial Teil 1 ( PDF )



  • So, jetzt wollte ich mir GTK auch endlich mal installieren, bekomme es aber auch nicht zum laufen. 😞

    Ich verwende als IDE MinGWStudio, mein Problem liegt darin, dass ich nicht weiß wohin ich "gtk-win32-devel-2.8.8-rc2.exe" und "gtkmm-devel-2.8.1-1.exe" installieren lassen soll, damit das MingGWStudio die include-Dateien findet. 😕



  • Du kannst ja in der IDE die Pfade hinzufügen.



  • Jep, aber da kam trotzdem eine file not found Meldung.
    Ich habe jetzt nochmal alles neu installiert, scheint jetzt zu funktionieren, er kompilliert den Code, kann die exe aber nicht ausführen.

    Bei Project kann ich nur "GTK+ Application" auswählen, ich will aber GTKmm oder?
    Kann man das irgendwie hinzufügen?



  • kann die exe aber nicht ausführen.

    Runtime Libraries mitinstalliert? Pfade gesetzt?

    ich will aber GTKmm oder?

    Ich würde wollen.

    Kann man das irgendwie hinzufügen?

    AFAIK nicht.



  • Klar habe ich die Runtime-Libs mitinstalliert, welche Pfade meinst du?



  • Er meint die Pfade die pkg-config ausspuckt wenn du es in der Konsole ausführst.

    Die Include Pfade die du alle einbinden musst bekommst du mit

    pkg-config --cflags gtkmm-2.4
    

    und alles libs und Pfade zu den libs bekommst du mit

    pkg-config --libs gtkmm-2.4
    

    das musst du dann alles mit angeben damit du dein projekt compilieren kannst.

    BR
    evilissimo



  • Danke, alles was

    pkg-config --cflags gtkmm-2.4
    

    zurückliefert habe ich bei Edit->Options->Directories->Include files hinzugefügt.
    Nur damit habe ich nichts anfangen können:

    /home/ivan/cross/build/include/cairo

    pkg-config --libs gtkmm-2.4
    

    liefert mir das:
    -LC:/GTK/lib -lgtkmm-2.4 -lgdkmm-2.4 -latkmm-1.6 -lgtk-win32-2.0 -lpangomm-1.4 -
    lglibmm-2.4 -lsigc-2.0 -lgdk-win32-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangowin32-1
    .0 -lgdi32 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lgl
    ib-2.0 -lintl -liconv

    Das müsste ich wohl bei Edit->Options->Directories->Libraray files hinzufügen, nur wie? 😕

    Tschuldigung wenn ich mich doof anstelle. 😕


Log in to reply