Windows Server 2003, Dateien über Internet freigeben


  • Mod

    - Kein FTP
    - Keine VPN-Verbindung

    - Zugriff muss auf Verzeichnisse beschränkt werden können (+ Read/Write), also am besten normale Benutzersteuerung
    - Alles muss hübsch clientseitig in einem Laufwerk gemappt werden

    - Übertragung der Daten wäre mir am liebsten verschlüsselt, aber wenn es denn sein muss geht es auch unverschlüsselt

    Das sollte doch straightforward möglich sein? Habe allerdings nichts gefunden. FileServer-Rolle funktioniert nur im Intranet, einfach eine Datei freigeben + Firewall abdrehen geht auch nicht...

    IIS wär installiert, aber ich will eigentlich keinen Upload/Download via WebDAV...

    Derzeit läuft leider SVN, die haben das zuerst nur für SourceCode benutzt und jetzt auch für normale Dateien. Das ist aber nun nicht mehr praktikabel...

    Edit: Kein Post ohne Frage: Wie kann ich das (möglichst einfach) realisieren?

    MfG SideWinder



  • Über den IIS geht das.
    Du kannst einen Dir-Scan freigeben auf dem IIS.
    Dann zeigt der Browser die Dateien an und man kann sie anklicken.
    Dateifreigabe ohne verschlüsselung geht auch übers INET.


  • Mod

    Unix-Tom schrieb:

    Über den IIS geht das.
    Du kannst einen Dir-Scan freigeben auf dem IIS.
    Dann zeigt der Browser die Dateien an und man kann sie anklicken.
    Dateifreigabe ohne verschlüsselung geht auch übers INET.

    Danke, ich würde es aber gerne in den Explorer integrieren.

    Dateifreigabe über Internet funktioniert? Bei mir nicht. Trotz ausgeschalteter Firewall. Gibt es etwas spezielles zu beachten dabei? Bzw. trotzdem: Welche Ports sind freizuschalten, evtl. hat mein Provider da noch einen Block in petto. Weißt du dazu etwas?

    MfG SideWinder


  • Mod

    Wenn ich mit Win7 darauf zugreifen will und ich die Diagnose starte, sagt er mir grundsätzlich nichts, unter Details findet sich aber:

    The device or resource (<IP>) is not set up to accept connections on port "The File and printer sharing (SMB)".

    Firewall ist wie gesagt kurzzeitig mal deaktiviert. Muss ich irgendeinen Dienst starten?

    Anders darauf zugreifen, als mit \<IP>\<SHARE> ?

    MfG SideWinder


  • Mod

    Niemand eine Ahnung woran das liegen könnte? 😞

    MfG SideWinder



  • Du musst die Dateifreigabe aktivieren.
    Nennt sich Datei und Druckfreigabe für Microsoftnetzwerke.
    Netzwerkeinstellungen.
    Ich glaube das es ab 2003 deaktiviert ist für Extern.


  • Mod

    Unix-Tom schrieb:

    Du musst die Dateifreigabe aktivieren.
    Nennt sich Datei und Druckfreigabe für Microsoftnetzwerke.
    Netzwerkeinstellungen.
    Ich glaube das es ab 2003 deaktiviert ist für Extern.

    Hab ich auch aktiviert.

    MfG SideWinder



  • Wenn Du die Firewall aus hast sollte das gehen. Es gibt sonst keine Einschränkung in Windows.
    Die Ports sind 137 bis 139.
    Kannst ja mal schauen ob die dann offen sind.


  • Mod

    Unix-Tom schrieb:

    Wenn Du die Firewall aus hast sollte das gehen. Es gibt sonst keine Einschränkung in Windows.
    Die Ports sind 137 bis 139.
    Kannst ja mal schauen ob die dann offen sind.

    Kann es sein, dass ich lokal bei mir (Windows 7, 64bit) irgendetwas in diese Richtung gesperrt habe?

    MfG SideWinder


  • Mod

    Was ich jetzt schon alles aktiviert habe:

    - Firewall aus
    - Datei- und Druckerfreigabe in der Netzwerkverbindung aktiviert
    - Directory freigegeben
    - Rechte für Anonymous in diesem Directory aktiviert

    Immer noch kein Zugriff aus dem Internet möglich 😞

    MfG SideWinder



  • Ports am Ausgangsrouter offen?



  • Gehst du überhaupt über einen Router?
    Wenn ja dann schau mal welches Gateway der Rechner hat.
    Hat er 2 Netzwerkkarten?
    Also dort wo du auf die Freigabe gehst muss auch dann die Route rausgehen.
    Sowas hatte ich mal bei 2 Netzwerkkarten.


  • Mod

    Ich glaube schon, dass es über einen Router geht...

    tracert zeigt ihn zwar nicht an, aber Gateway ist .1 bei der Netzwerkverbindung von zweien bei der ich glaube über die geht es.

    Die Firewall ist aber gleich für alle Netzwerkverbindungen soweit ich das sehe...oder kann man die einzeln auch noch einmal konfigurieren?

    MfG SideWinder


  • Mod

    Aktiv scheint aber nur eine zu sein. Die anderen sind deaktiviert.



  • Moment. Du hast also mehrere Netzwerkkarten?
    Eine davon auf eine externe IP?
    Eine davon auf eine Interne mit Gateway .1 ?

    Dann hast Du das Problem das er jede anfrage über das Gateway routen möchte.


  • Mod

    Ich habe da drei Verbindungen:

    LAN1 - Connected, Firewalled.
    LAN2 - Disabled, Firewalled. (Ich glaube hierüber werden die Backups gemacht oder so, handelt sich um einen gemieteten Server mit inkludierten Backups)
    VPN - Network cable unplugged, Firewalled.

    Bei ipconfig kommt nur LAN1 mit IP (die auch über das Internet erreichbar ist), Subnetmask und Gateway (IP mit 1 hinten).

    tracert schickt Pakete aber offenbar nicht über den Gateway (bzw. scheint der in der tracert-Route nicht auf?)

    Der Server ist sonst erreichbar (bspw. läuft SVN, IIS mit ASP.NET (Sessions), MSSQL,etc.) alles perfekt erreichbar.

    Die Dateifreigabe kann da doch nicht einfach andere Wege gehen?

    MfG SideWinder


  • Mod

    SVN geht über Port 8443 TCP, sollte also auch nicht im Weg stehen.

    netstat -A -n liefert:

    Active Connections
    
      Proto  Local Address          Foreign Address        State
      TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
      TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
      TCP    0.0.0.0:1027           0.0.0.0:0              LISTENING
      TCP    0.0.0.0:1136           0.0.0.0:0              LISTENING
      TCP    0.0.0.0:1311           0.0.0.0:0              LISTENING
      TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING
      TCP    0.0.0.0:8443           0.0.0.0:0              LISTENING
      TCP    0.0.0.0:10433          0.0.0.0:0              LISTENING
      TCP    0.0.0.0:47001          0.0.0.0:0              LISTENING
      TCP    <IP>:135       <IP>:1034      ESTABLISHED
      TCP    <IP>:135       <IP>:1080      ESTABLISHED
      TCP    <IP>:139       0.0.0.0:0              LISTENING
      TCP    <IP>:990       0.0.0.0:0              LISTENING
      TCP    <IP>:1034      <IP>:135       ESTABLISHED
      TCP    <IP>:1080      <IP>:135       ESTABLISHED
      TCP    <IP>:3389      <MEINE_CLIENT_IP>:55818     ESTABLISHED
      TCP    <IP>:3389      <MEINE_CLIENT_IP>:64264     ESTABLISHED
      TCP    127.0.0.1:1031         0.0.0.0:0              LISTENING
      TCP    127.0.0.1:34119        0.0.0.0:0              LISTENING
      UDP    0.0.0.0:445            *:*
      UDP    0.0.0.0:1434           *:*
      UDP    <IP>:137       *:*
      UDP    <IP>:138       *:*
    

    MfG SideWinder



  • SideWinder schrieb:

    Unix-Tom schrieb:

    Wenn Du die Firewall aus hast sollte das gehen. Es gibt sonst keine Einschränkung in Windows.
    Die Ports sind 137 bis 139.
    Kannst ja mal schauen ob die dann offen sind.

    Kann es sein, dass ich lokal bei mir (Windows 7, 64bit) irgendetwas in diese Richtung gesperrt habe?

    MfG SideWinder

    Viele ISPs sperren diese Ports.
    Ich würde die auch tunlichst nicht aufmachen.
    Wenn dann Port 445, der sollte ausreichend sein für SMB.
    Und verwende einen User mit Namen, nicht den Guest Account. Damit der Guest Account funktioniert muss man soweit ich weiss noch einiges umstellen.

    Oder eben doch FTP/VPN/WebDAV. WebDAV ginge auch über SSL.


  • Mod

    OMG ich glaube ich habe heute das Problem gefunden. Ein und derselbe User kann offenbar nicht gleichzeitig via Remote Desktop eingeloggt sein und auf die Daten zugreifen.

    Ist das die Möglichkeit? Jedenfalls scheint es jetzt zu funktionieren.

    Danke für eure lange Hilfe!

    MfG SideWinder



  • SideWinder schrieb:

    OMG ich glaube ich habe heute das Problem gefunden. Ein und derselbe User kann offenbar nicht gleichzeitig via Remote Desktop eingeloggt sein und auf die Daten zugreifen.

    Ist das die Möglichkeit? Jedenfalls scheint es jetzt zu funktionieren.

    Nein, daran liegt's nicht, das mache ich in der Firma öfter mal, und wir verwenden auch 2003 Server (R2 allerdings, aber das dürfte keinen Unterschied machen).
    p.S.: "ich mache es öfter mal" heisst es funktioniert auch problemlos 🙂


Log in to reply