gtk+ ubuntu



  • Hey Leute,
    hatte mir Letztens gkt+ standardmäßig installiert also übers terminal.
    leider hätte ich da wohl recht viel in dem Code änderen müssen da der Pfade nicht stimmt. Also zog ich mir nochmal die zip. Leider bin ich zu blöd die lib's zu erstellen.
    hatte es dann wie in der Anleitung steht gemacht
    ./configure
    hat geklappt
    make

    Makefile:571: recipe for target 'libglib-2.0.la' failed
    make[4]: *** [libglib-2.0.la] Error 1
    make[4]: Verzeichnis „/home/user/Schreibtisch/glib-2.9.0/glib“ wird verlassen
    Makefile:755: recipe for target 'all-recursive' failed
    make[3]: *** [all-recursive] Error 1
    make[3]: Verzeichnis „/home/user/Schreibtisch/glib-2.9.0/glib“ wird verlassen
    Makefile:529: recipe for target 'all' failed
    make[2]: *** [all] Error 2
    make[2]: Verzeichnis „/home/user/Schreibtisch/glib-2.9.0/glib“ wird verlassen
    Makefile:487: recipe for target 'all-recursive' failed
    make[1]: *** [all-recursive] Error 1
    make[1]: Verzeichnis „/home/user/Schreibtisch/glib-2.9.0“ wird verlassen
    Makefile:341: recipe for target 'all' failed
    make: *** [all] Error 2
    

    hab dazu jezt auch nicht weiter viel gefunden vieleicht hatte ja mal jemand das selbe problem

    Danke schon mal
    MFF



  • in den Code- änder müssen da der pfade nicht stimmt

    Was?



  • #include<gtk-3.0/gtk/gtk.h>
    
    

    das ist jezt nur ein beispiel :

    #include <glib/gmacros.h> 
    

    jedenfalls sind die Header in einen andern Ordner als in den Headern angegeben gegeben was leicht nervt. da ich immer den neuen pfad angeben muss oder die Datei verschieben darf.



  • sry war gnauso blöd wie ich :'D



  • Deine includes sind halt falsch. Mach es richtig, dann geht es auch: #include<gtk/gtk.h>



  • die .h sind in 3.0.0 also gtk-3.0.0/
    von den glibs will ich garnicht reden die sind im halben system verstreut hab ich das gefühl.
    um das sortieren zu vermeiden
    wollt ich halt die jezt tar.gz mit make install installieren
    da kam halt der oben erwähnte fehler



  • @Abe

    die .h sind in 3.0.0 also gtk-3.0.0/

    Nein! Das gibst du dem Compiler auf der Kommandozeile mit.



  • okay das verstehe ich jezt nicht leider

    #include<gtk-3.0.0/gtk/gtk>
    //der installiere pfade 
    

    hab die jezt mit cp einfach rauskopiert
    also nur noch:

    #include<gtk/gtk.h>
    

    hab ich mit den glib auch gemacht hatte halt keine andere idea mehr als das so zu lösen
    nur hab ich nun das Problem das die glib Version nicht stimmt.
    daher wollte ich mir gtk und glib als tra.gz ziehen und maken
    das oben ist jetzt glib die Fehlermeldung nach make



  • Unter Linux solltest du pkg-config verwenden um die Pfade der Header/Libs zu ermitteln.

    Mit pkg-config --cflags gtk+-3.0 solltest du die nötigen include Pfade 'compilergerecht' erhalten.



  • War von mir auch ein etwas unbedachter Titel das Problem ist in der glib.
    und funktioniert so leider nicht. die glib ist 2.0 und ich brauche 2.3.6 oder größer so deswegen versuch ich gerade 2.9 zu installieren



  • Unter Ubuntu 18.04 werden bei mir mit dem package libglib-2.0-dev die Header/Libraries von glib 2.56.4 installiert. Was willst du also mit Version 2.9.x ?



  • "GLIB_VERSION_MIN_REQUIRED must be >= GLIB_VERSION_2_26"
    

    das bekomme ich als Fehlermeldung muss ich da ein define setzen ?
    Sowas wie bei glfw hab ich da nicht gefunden



  • Du musst garnichts definieren. Entferne erstmal alle selbst kopierten/compilierten Dateien aus dem System und (re)installiere das package libglib-2.0-dev.



  • ja jetzt habe ich das Problem mit den Verzeichnissen wieder.



  • Verwende beim Aufruf des Compilers `pkg-config --cflags glib-2.0` (beachte die "backticks"), und zum linken `pkg-config --libs glib-2.0`. Damit werden dem Compiler die korrekten include Pfade und Libraries bekannt gemacht.





  • This post is deleted!


  • @osdt hab das jezt hinbekomm nur kommt jetz

    `pkg-config --cflags gtk+-3.0`
    Package 'cairo' requires 'glib-2.0 >= 2.14' but version of glib-2.0 is 2.9.0
    

    diese Fehlermeldung



  • @Abe sagte in gtk+ ubuntu:

    `pkg-config --cflags gtk+-3.0`
    Package 'cairo' requires 'glib-2.0 >= 2.14' but version of glib-2.0 is **2.9.0**
    

    Du hast wahrscheinlich glib 2.9.0 selbst compiliert und nach /usr/local installiert (sudo make install) ? Entferne den Müll 😉



  • Okay ich bekomms nicht weg 😅


Log in to reply