Probleme mit QT 3.4



  • Hi !

    Ich hab ein Programm mit QT 3.3 geschrieben. Da ich auf Suse 9.3 geupdated hab, was ja QT 3.4 verwendet erhalte ich nun die Ausgabe:

    ./LevelEditor: error while loading shared libraries: libqt.so.3: cannot open shared object file: No such file or directory
    

    Vorher lief das Programm ohne Probleme. Also dachte ich, ich kompilier es nochmal denn ich hab ja alle Devel Pakete die nötig sind installiert. Also qmake -project. Aber leider erhielt ich die Meldung:

    bash: qmake: command not found
    

    Tja, vielleicht ein Fehler von Suse. Also Suse Devel RPMs gelöscht und QT von der Trolltech Seite geladen ./configure , make , make install und die Umgebungsvariablen in der .profile gesetzt und fertig. Leider findet er immer noch nicht qmake.

    Allerdings befindet sich qmake kompiliert im Verzeichnis "/home/tom/qt-x11-free-3.3.4/qmake" also in dem Verzeichnis in dem ich make ausgeführt habe, bzw hat make install scheinbar nicht das gemacht was es machen soll. qmake funktioniert nun auch wenn es auch ein wenig umständlich beim Aufruf ist. Also hat mir qmake jetzt ein Makefile erstellt. Führe ich nun make auf meinen Quellcode aus erhalte ich dann folgenden Fehler:

    g++ -c -pipe -Wall -W -O2  -DQT_NO_DEBUG -I/home/tom/qt-x11-free-3.3.4/mkspecs/default -I. -I. -I/usr/local/qt/include -o Block.o Block.cpp
    In file included from Block.cpp:1:
    Block.h:4:21: qcanvas.h: Datei oder Verzeichnis nicht gefunden
    In file included from Block.cpp:1:
    Block.h:10: error: type specifier omitted for parameter `QCanvasSprite'
    Block.h:10: error: syntax error before `*' token
    Block.h:11: error: type specifier omitted for parameter `QCanvasSprite'
    Block.h:11: error: syntax error before `*' token
    Block.h:12: error: type specifier omitted for parameter `QCanvasSprite'
    Block.h:12: error: syntax error before `*' token
    Block.h:13: error: type specifier omitted for parameter `QCanvasSprite'
    Block.h:13: error: syntax error before `*' token
    usw....
    

    ldconfig habe ich auch schon sepereat ausgeführt. Leider hat bis jetzt nichts geholfen.

    Tom



  • Hoppla, hab leider vergessen qt nach /usr/local zu verschieben. Jezt funktioniernts


Log in to reply