Compile fehler - welche lösung?



  • Hallo,

    ich programmiere in vc++ 6.0 und bekomme beim compilieren folgenden fehler:

    😕\*** **\ \ \*************\*************\\.h(7) : fatal error C1083: Include-Datei kann nicht geoeffnet werden: '**.h': No such file or directory**

    Wie kann ich das problem lösen? Vielen dank im vorraus!

    Mfg



  • Du korrigierst den Rechtschreibfehler in deinem Dateinamen. 😉



  • Die Header-Datei die du per Include einbinden willst existiert ganz einfach nicht, beziehugnsweise nicht an den Suchpfaden des MSVC.

    Du kannst die Suchpfade unter Einstellungen -> Verzeichnisse anpassen.

    BTW: Muss dieses Hardcore-Verwischen deines Pfades sein *g*, vor allem der Name der Header-Datei wäre interessant. Eventuell ein Schreibfehler 😃

    MfG SideWinder



  • ...****\d3d9.h(7) : fatal error C1083: Include-Datei kann nicht geoeffnet werden: 'd3d9.h': No such file or directory

    Ich hab die dateinamen jetzt kontrolliert, es ist nichts falsch geschrieben!
    Ich werde jetzt mal das Verzeichnisse anpassen probieren! Danke für die tips!

    Mfg



  • Ich weiß nicht genau, was ich bei den einstellungen umstellen sollte ?!

    Mfg



  • hallo

    wenn ich mich recht erinnere gab's mal eine schulversion von turbo c++ 4.5,
    da wurden meiner ansicht nach headerdateien, die mit dem compiler geliefert
    wurden teilweise umbenannt, dies wurde jedoch nicht in allen compiler-header-
    dateien angepasst(mal mussten 1 oder 2 buchstaben mehr oder weniger). dieser
    effekt trat vor allem bei den header-dateien auf, die benötigt wurden um
    älteren für turbo c++ 3.0 geschriebenen source code zu übersetzen.

    ist halt ärgerlich wenn der compiler-hersteller solche bug's ausliefert.
    dieses ist mir bisher noch bei keinem anderen compiler aufgefallen; aber
    sollte dies tatsächlich ein einzelfall sein?
    bei tools von fremdanbietern ist mir dies schon öffter untergekommen.

    na gut um bestimmte projekte zu übersetzen, wenn ich nicht die neueste com-
    pilerversion hatte, hab ich auch schon mal die orginal-headerdateien ergänzt
    (geschaut was der compiler eines anderen herstellers machte und entsprechende
    add-dateien geschrieben um z.b. möglichst kleinen code zu erhalten).
    dies sollte aber bei tools, die dies benötigen, dokumentiert werden.

    andere fehlermöglichkeit sind beim einrichten des compilers die pfade richtig
    gesetzt? z.b. in der IDE, ev. projekt, make oder cfg-datei.
    der letzte punkt sollte zuerst geprüft werden.

    mfg f.-th.



  • nachtrag: ich kenne den vc nicht. aber such mal deine hdd's ab, ob überhaupt
    einen sollche datei vorhanden ist.

    mfg f.-th.



  • ok, vielen dank!

    mfg



  • ich glaub' ich konnte's rekonstruieren!:

    epic schrieb:

    [b]v:\o**ausvo*\*aus** stand\ar* vo**au\svo* aus*\sta_ndar*stand_ar**\vor_**aus*stan_dar*\*****\****.h(7)

    (ist aber noch nicht komplett) 😃

    bin ich jetzt 1337 oder was?



  • Nichts besseres zu tun, was ? 🙄

    Hab das problem jetzt erledigt, mir hat die D3D9 SDK gefehlt!

    Mfg



  • epic schrieb:

    Nichts besseres zu tun, was ?

    mann, bist du gut! wie hast du das denn erraten? 😮
    respekt. 😉


Log in to reply