error LNK2019 / strmbasd.lib



  • Hallo ich habe bei meinenm Programm folgendes Problem:

    error LNK2019: Nicht aufgelöstes externes Symbol '"public: __thiscall CBaseVideoRenderer::CBaseVideoRenderer(struct _GUID const &,char *,struct IUnknown *,long *)" .....

    Ich denke aber dass ich die notwendigen Libaries included habe.

    strmbasd.lib
    strmiids.lib
    winmm.lib

    außerdem habe ich die Headerdatei streams.h eingefügt.

    Ließt man in der MSDN Hilfe nach, dann steht darin, dass man für die BaseViedeoRenderer class strmbase.lib benötigt. Diese Libarary habe ich mir vom Internet heruntergeladen. Wenn ich nun die strmbase.lib include passiert gar nichts bzw es entstehen noch mehr Link errors wenn ich strmbasd.lib weglasse.

    Es wäre schön, wenn mir jemand helfen könnte!!!!



  • Ich hatte mal ein ähnliches Problem (ein anderer Filter, aber die selbe Library) - bist du dir sicher, daß du die richtige streambasd.lib eingebunden hast? Eventuell könnten sich die Parametertypen geändert haben - und das wirkt sich auf den fertigen Namen der Funktion aus.



  • ja ich denke schon.

    Ich weiß nicht ob du es weißt, aber die strmbasd.lib ist in keiner Standartlibary enthalten.
    Darum habe ich mir die strmbasd.lib mit dem Programm aus

    C:\Programme\SDK Summer2004\... \sample\directshow\baseclasses

    generiert.
    Wie das geht kann man in verschiedenen DirextX Tutorials nachlesen. Ich denke ich habe dabei nichts falsch gemacht.

    Ist es möglich dass ich das falsche SDK verwende?

    Oder hat sonst irgendwer eine Ahnung woher ich eine funktionierende strmbasd.lib herbekomme?

    DANKE!!!!!



  • Und aus welchem Verzeichnis wird die zugehörige "streams.h" eingebunden? Hoffentlich aus dem selben.



  • Ja sicher aus dem gleichen Verzeichnis. Ich habe gerade noch einmal nachgeschaut.



  • Ich habe zu diesem Thema auch noch in das DirectX Forum geschrieben, da ich denke, dass dies kein reines WinAPI Problem mehr ist.


Log in to reply