Verwenden einer Liste bzw. eines Vektors



  • Ein recht einfaches Problem:

    Ich habe ein Stück Code, das in Visual C++ .Net 2003 einwandfrei
    kompliert, aber nicht in Visual C++ 6.0.
    Es geht um STL-Listen bzw. -Vektoren (bei beiden jeweils das gleiche Problem):

    // Deklarationen
    #include <list>
    #include <vector>
    using std::list;
    using std::vector;

    //Liste aus Zeigern auf Instanzen(Objekten) der Klasse "Klassenname" anlegen.
    //
    list<Klassenname*> klassenname; // ok
    list<Klassenname*>::iterator klassennameI; // Compiler-Fehler in VC++ 6.0

    //Analog:
    //Vektor aus Zeigern auf Instanzen(Objekten) der Klasse "Klassenname" anlegen.
    //
    vector<Klassenname*> klassenname; // ok
    vector<Klassenname*>::iterator klassennameI; // Compiler-Fehler in VC++ 6.0

    Wie gesagt, übersetzt dies mit .NET einwandrei, mit dem alten
    6.0 jedoch nicht. VC 6.0 scheint den "iterator" nicht zu kennen.
    Ich denke die Syntax ist korrekt. Auch die Funktionalität ist in .NET
    tadellos.
    Habt Ihr eine Idee ?



  • Hallo

    VC6 gilt als veraltet und nicht standardkonform. Benutz einen aktuellen Compiler, dann geht das auch.

    bis bald
    akari



  • daniel76er schrieb:

    Wie gesagt, übersetzt dies mit .NET einwandrei, mit dem alten
    6.0 jedoch nicht. VC 6.0 scheint den "iterator" nicht zu kennen.
    Ich denke die Syntax ist korrekt. Auch die Funktionalität ist in .NET
    tadellos.
    Habt Ihr eine Idee ?

    Mit .NET hat das ganze überhaupt nichts zu tuen... 😮

    grüße



  • Hallo

    David_pb schrieb:

    daniel76er schrieb:

    Wie gesagt, übersetzt dies mit .NET einwandrei, mit dem alten
    6.0 jedoch nicht. VC 6.0 scheint den "iterator" nicht zu kennen.
    Ich denke die Syntax ist korrekt. Auch die Funktionalität ist in .NET
    tadellos.
    Habt Ihr eine Idee ?

    Mit .NET hat das ganze überhaupt nichts zu tuen... 😮

    grüße

    Er wird Visual Studio .NET meinen und wie gesagt, dass liegt wahrscheinlich daran, dass der Compiler von VS6 veraltet ist.

    chrische


Log in to reply