kann DLL nicht explizit laden.



  • Hallo,

    ich probiere mich gerade an DLLs und verwende als Hilfe das C++ Buch von Richard Kaiser.

    Ich habe es schon geschaft eine DLL zu erzeugen und diese implizit zu laden. Nun möchte ich jedoch dieselbe DLL explizit laden. Jedoch gibt mir die Funktion LoadLibary() immer nur NULL zurück, die Auswertung von GetLastError ergibt immer "unzulässiger zugriff auf einen speicherbereich". Ich habe jedoch die DLL im selben Verzeichnis wie das Aufrufer Programm. Kann mir jemand helfen?

    Greets



  • Ein Moegliches Problem das mir einfaellt haengt mit der Entwicklungsumgebung zusammen:
    Ich benutze Visual Studio und da ist das mit dem relativen Pfad so ne Sache: Die EXE wird zwar in [solution-name]\debug gespeichert, fuehrt man das Programm allerdings von der IDE aus aus ist das Verzeichnis des Programms [solution-name][project-name], also da wo auch die Quelldateien liegen. Um sicherzustellen das die Ursache nicht sowas triviales ist, pack die entsprechende DLL doch einfach mal in dein System32-folder.



  • Hi,

    hmmm weiss ned ob es das is was ich denke aber schau dir doch mal den HABO-WIKI an.
    Da wird dll-injection ausführlich beschrieben.

    Lg



  • Muhi89 schrieb:

    Hi,

    hmmm weiss ned ob es das is was ich denke aber schau dir doch mal den HABO-WIKI an.
    Da wird dll-injection ausführlich beschrieben.

    Lg

    Was hat das denn bitte mit Seinem Problem zu tun ? 😕



  • Ok sry hab da was falsch verstanden.


  • Mod

    Was zeigt sich denn im Debug Ausgabe Fenster?
    Welche Erronummer ist das die GetLastError zurückliefert?


Log in to reply