@Jochen oder Martin: vc_redist von SP1 abwärtskompatibel?



  • Hi,

    ich habe gerade das Problem, dass unsere Hauptanwendung mit VS 2005 kompiliert ist, ein Zusatztool aber mit VS 2005 SP1. Auf dem Kundensystem läuft das Zusatztool nicht, da dort nur die DLLs vom Visual Studio installiert sind, aber nicht die von SP1.
    Jochen empfiehlt vc_redist zu installieren.
    Bevor ich das beim Kunden mache möchte ich aber sicher sein, dass es da keine anderen Auswirkungen hat... Die Hauptanwendung sollte auch weiterhin laufen. Da die Stimmung beim Kunden nciht die Beste ist, möchte ich ein rumprobieren tunlichst vermeiden...

    Danke für eure (schnelle :)) Antwort.


  • Mod

    Ui! Eine persönliche Anfrage!

    Also Wir sindnoch nicht produktiv mit 2005 (geschweige denn SP1)
    Aber ich habe eine Antwort:
    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1044158&SiteID=1

    Ganz besonders die von Nilor Dudar! Der weiß von was er schreibt und kommt mit Sicherheit nicht aus dem Marketing 😉

    Kurzgefasst: Ja! Die Runtime von 2005 SP1 sind abwärtskomatibel.

    Siehe auch:
    http://msdn2.microsoft.com/en-us/library/aa983349(VS.80).aspx
    Und denke gar nicht erst daran _USE_RTM_VERSION zu verwenden! Das wird ganz wieder schnell verschwinden...

    Mich wundert nur der Satz:
    We have no plans of posting SP1 version of VCRedist for download. You should be using version of vcredist_.exe installed by VS2005 SP1.*
    Aber über den wundern sich noch mehr...

    HTH



  • Martin Richter schrieb:

    Mich wundert nur der Satz:
    We have no plans of posting SP1 version of VCRedist for download. You should be using version of vcredist_.exe installed by VS2005 SP1.*
    Aber über den wundern sich noch mehr...

    HTH

    Er meint wohl die vcredist_*.exe die das SP1 in
    ...\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\...

    abgelegt hat, oder ?


  • Mod

    Ja!
    Aber die Aussage heißt weiterhin:
    Man kann die redistributables nicht separat runterladen... Wieso? Wenn es vc_redist aus dem RTM zum so herunterladen gibt, sollte SP1 auch frei verfügbar gemacht werden...
    Die Aussage ist einfach dämlich!
    Sorry für die Härte...



  • Les mal auf Seite 2 weiter 😉

    -> Der Download ist in Arbeit


  • Mod

    Danke! Ich war mal wieder zu faul...



  • Das Problem ist nämlich, das Nikola vermutlich gedacht hat, das dieses vcredist bei *allen* VC Versionen dabei ist... aber es ist eben bei der VC-Express-Edition *nicht* dabei. Deshalb hoffe ich schwer, dass der Download bald zur Verfügung steht...


Log in to reply