magic numbers



  • was haltet ihr von solchem code:

    private void attachSupplementalDocuments()
    {
      if (stateCode == "AZ" || stateCode == "TX") {
        //SR008-04X/I are always required in these states
        attachDocument("SR008-04X");
        attachDocument("SR008-04XI");
      }
    
      if (ledgerAmnt >= 500000) {
        //Ledger of 500K or more requires AUTHLDG-1A
        attachDocument("AUTHLDG-1A");
      }
    
      if (coInsuredCount >= 5  && orgStatusCode != "CORP") {
        //Non-CORP orgs with 5 or more co-ins require AUTHCNS-1A
        attachDocument("AUTHCNS-1A");
      }
    }
    

    ttwtf sagt, das ist gar nicht so schlecht: http://worsethanfailure.com/Articles/Soft_Coding.aspx



  • Mieser Code, mieser Artikel.



  • finix, was gefällt dir denn an dem Artikel nicht?

    Ich behaupte: der Artikel ist sehr gut, das beschriebene Problem sehr real und eben auch sehr treffend zusammengefasst. Wenn dir was nicht passt würde ich gerne wissen WAS und WARUM.



  • Passend dazu: Vorhin wollte ich mal eben die Blinkgeschwindigkeit des Cursors von der KDE-Konsole ändern. Die 1000ms waren an 3 verschiedenen Stellen im Code verstreut. Und jetzt steht da drin: blink->start(500); // 1000ms 👍

    Die Beispielfunktion da ist nun sehr speziell... prinzipiell sehe ich Stringkonstanten lieber als VAR statt "VaR". Spätestens wenn dieselbe öfter vorkommt.


Log in to reply