Problem mit SuSE und GRUB



  • Hi,
    ich hab gerade SuSE Linux 8.1 Prof. installiert (ohne den Bootmanager GRUB auszuwählen). Beim Neustarten, nach der Installation, kam BootMagic (ist ja soweit noch in Ordnung), aber ohne Linux. Nachdem ich Linux dann bei BootMagic angemeldet hatte, erschien auch Linux in BootMagic, doch sobald ich das Teil boote, kommt die Konsole (oder wie man das auch immer nennt) mit 'GRUB > ' und da fängt das Problem an - wie setze ich die Installation fort / starte Linux ?

    Danke im Voraus

    M.T.



  • Hi !

    Du hast Grub die falschen Einstellungen gegeben, deshalb kommt dieser Fehler.

    Wie kommt man weiter ?

    Grub > root (hd0,0) [enter] <-- wo ist grub installiert
    Grub > setup (hd0) [enter]
    Grub > kernel (hd0,0)/boot/bzImage [enter] <-- pfad des kernels
    Grub > boot [enter] <-- was wohl ?

    Wenn du so in dein System gekommen bist (Partitionen natürlich anpassen), musst du die /boot/grub/menu.lst bearbeiten, und in der Konsole grub eingeben.
    Gleiche Eingaben wie oben machen !



  • Hi Headhunter,
    danke erst mal, doch bei allen Kommandos gibt er mir nach der Eingabe ein 'unrecognized command' aus. Heißt das etwa, dass er den Befehl nicht kennt? Ohne Parameter kennt er den Befehl zwar, macht aber auch nichts :(. Muss hd[...] die Partition sein, auf der Linux installiert wurde? - Wie bekommt man die am besten raus ? Und was bedeutet das ',0' als Parameter ?

    M.T.



  • > Und was bedeutet das ',0' als Parameter ?

    GRUB verwendet ein anderes Benennungsschema wie Linux

    Linux       GRUB
    /dev/hda    hd0
    /dev/hda1   hd0,0
    /dev/hda2   hd0,1
    /dev/hda3   hd0,2
    
    /dev/hdb    hd1
    /dev/hdb1   hd1,0
    /dev/hdb2   hd1,1
    /dev/hdb3   hd1,2
    
    /dev/hdc    hd2
    /dev/hdc1   hd2,0
    /dev/hdc2   hd2,1
    /dev/hdc3   hd2,2
    
    usw.
    

    siehe Abschnitt "Naming convention" in der InfoPage zu grub ("info grub")



  • Manuel :

    Ich hoffe du hast nicht "Grub > root (hd0,0) [enter] <-- wo ist grub installiert" eingegeben ??

    "root (hd0,0)" ist schon genug 😉



  • @ Headhunter : ich bin zwar Linux-Neuling, aber sowas 😃

    ->Ich werds noch mal testen und zur Not, neu installieren.

    Danke und ein gutes neues Jahr

    M.T.



  • Hier hatte jemand ein ähnliches Problem :

    http://forums.gentoo.org/viewtopic.php?t=28253


Log in to reply