php Seite lokal Ausführen / Apache problem / Port belegt



  • Ich hab alle php Skripte und resourcen einer Internetseite, und würde diese gerne lokal auf meinem Rechner starten.

    Es ist das erste mal, das ich überhaupt etwas mit php oder webzeug zu tun habe.

    Ich hab mir erstmal XAMPP heruntergeladen, und installiert, weil ich denke, dass das das richtige ist (ist Apache mit drin). Allerdings kann ich Apache nicht starten der sagt was von port 80 schon belegt.

    make_sock: could not bind to address 0.0.0.0:80
    no listening sockets aviable, shutting down
    

    Wie kann ich überhaupt herausfinden, welches Programm auf den Port zugreift?
    Da ich meine Seite wirklich erstmal nur offline Testen möchte, ist es da denn überhaup nötig, dass der zu einem Port eine Verbindung aufbaut? Wenn nein, wie kann ich dann verhindern, dass das Programm sofort wieder beendet.



  • Krux schrieb:

    Wie kann ich überhaupt herausfinden, welches Programm auf den Port zugreift?

    netstat -an

    Krux schrieb:

    Da ich meine Seite wirklich erstmal nur offline Testen möchte, ist es da denn überhaup nötig, dass der zu einem Port eine Verbindung aufbaut?

    Du musst tcp/ip verwenden. Also brauchst Du auch ein Port. Du kannst diesen aber auch in der httpd.conf einstellen und in der Browser-URL angeben. Ob dann aber auch Weiterleitungen usw klappen,weiß ich nicht.



  • mit "netstat -an" kann ich nur herausfinden, welche ports abgehört werden, allerdings weiß ich immer noch nicht welches Programm das ist. Hier meine Ausgabe:

    Protokoll  Lokale Adresse remoteadresse Status
    TCP        0.0.0.0:80     0.0.0.0:0     ABHÖREN
    ...
    

    Die Liste geht noch weiter ist aber wenig hilfreich

    Da es mein absolut erstes mal mit Apache ist, wäre es echt hilfreich, wenn du erwähnen könntest, was ich denn ich die httpd.conf datei schreiben soll, um das besagte Ziel zu erreichen.



  • würde schaun, welche programme laufen..

    typischerweise sind skype oder irgenwelche messenger die blockierer 😉



  • whohoo, danke skype ist schuld gewesen

    edit:
    zu früh gefreut, jetz ist zwar laut xampp apache am laufen, aber wenn ich auf die Seite gehen will, gibts folgendes

    Zugriff verweigert!
    
    Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
    
    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
    Error 403
    

    also vom Browser aus gesehen. Wenn ich von XAMPP aus bei Apache auf Admin gehe, komme ich auf die selbe seite.

    edit2:
    ok das war offensichtlich ein Problem mit dem Tutorial, welches ich benutzt habe, um meine eigene Seite aufrufbar zu machen, jetzt geht das Apache admin wieder, aber meine Seite immer noch nicht.

    edit3:
    jetzt klappt alles, nur die Umlaute nicht, aber die sind mir jetz auch egal.


Log in to reply