tex



  • hallo ich verwende unter windows
    texnic center für meine latex files

    nun wollte ich ein assemblerbeispielprogramm einfügen :

    \begin{lstlisting}
    addi sp,4sp, -4
    \end{lstlisting}

    dumm ist nur dass meine umgebung denkt dass $ eine mathematische umgebung anführt und alles danach grün malt das ist extrem störend.
    wie kann man das ändern?



  • \$



  • das geht leider auch nicht da
    die listing umgebung ja alles wörtlich nimmt was ich schreibe...

    wenn ich da \$ eingebe steht in der ausgabe auch \$

    is halt des problem mit zitaten



  • Vielleicht interessiert es dich ja: Ich habe auch mal mit Texniccenter hantiert. Nach viel probieren mit Texmaker und zuletzt eisernem Emacs-Lernen habe ich nun endlich mal eine IDE gefunden, die (zumindest für mich) perfekt scheint für Latex unter Windows: Eclipse mit der Erweiterung Texlipse.
    Da wird übrigens auch Dein $ richtig (also nicht) eingefärbt. Hab's grad mal probiert.



  • danke wirdbald ich werd demnäöchst mal ausprobieren...
    sch.. windows mit texniccenter

    kile ist da um meilen besser 🙂



  • bitte Versuch in Zukunft bessere Topics zu benutzen. "tex" ist zwar schon ein richtiger Ansatz, aber noch nicht gut! So etwas wie "tex: $ in lstlisting" wäre doch schon viel besser...

    🙂



  • Auf Seite 37 im User Guide von lstlisting steht, wie man in listings verhindern kann, dass $ ein spezielles Zeichen ist; du musst nur für deinen konkreten listing-Typ die Option "mathescape=false" setzen.


Log in to reply