Microsoft Visual C++ 2008 Express Edition - WC Kandidat?



  • Kackt bei euch die IDE auch so oft beim Debuggen ab? Und das bei einem Kompilat, das fehlerfrei läuft!
    Hab heute schon 6 mal den PC neu gestartet. 😡
    👎



  • vc n00b schrieb:

    Kackt bei euch die IDE auch so oft beim Debuggen ab? Und das bei einem Kompilat, das fehlerfrei läuft!
    Hab heute schon 6 mal den PC neu gestartet. 😡
    👎

    Nein, macht sie normalerweise gar nicht. Irgendwas stimmt bei dir nicht. Installier mal neu.

    EDIT: Und denk ans SP1.



  • _matze schrieb:

    EDIT: Und denk ans SP1.

    Meinst du für die IDE oder WinXP?



  • vc n00b schrieb:

    _matze schrieb:

    EDIT: Und denk ans SP1.

    Meinst du für die IDE oder WinXP?

    Die IDE (guck mal auf msdn.com). Für XP solltest du aber natürlich auch mindestens SP2 drauf haben...



  • Sind da schwebende Fenster im Spiel? Ist ein bekanntes Problem:

    http://blogs.catalystss.com/blogs/christopher_v_domino/archive/2008/08/25/visual-studio-2008-service-pack-1-floating-window-debug-bug.aspx (mit Link zu Bug-Report bei Microsoft)

    Ich kann den Absturz umgehen, indem ich nicht mit F5 das Debuggen starte, sondern mich an den Prozeß anhänge (Attach to process...).



  • @pnoom :
    Gibt es denn dafür wirklich keine Lösung ??

    Genau das Problem hab ich seit ein paar Minuten auch, aber selbst über Attach to Process funktioniert es nicht !

    Meine Anwendung funktioniert, per Druck auf F5 (oder auch über Attach to Process) "hängen" plötzlich alle Windows in der Luft und zu benutzen sind die auch nicht mehr.
    Reboot, ncb-File löschen oder IDE neustarten hilft auch nicht !

    Da geht mir aufn ****, kann so nicht arbeiten ! 😡



  • R3dNeXX schrieb:

    @pnoom :
    Gibt es denn dafür wirklich keine Lösung ??

    Vorerst gibt es wohl nur die Lösung, sich damit zu arrangieren, also auf schwebende Fenster beim Debuggen zu verzichten oder das Debuggen nicht mit F5 zu starten. Das scheint bei dir aber auch nicht zu funktionieren.

    Vielleicht zeigt sich Microsoft ja auch irgendwann mal gnädig und veröffentlicht ein Hotfix.



  • pnoom schrieb:

    Vielleicht zeigt sich Microsoft ja auch irgendwann mal gnädig und veröffentlicht ein Hotfix.

    Da bin ich ja mal gespannt ! 🙂

    Habe es jetzt (temporär) erstmal gelöst, indem ich die flügge-gewordenen 😃 Windows wieder an ihre ursprüngliche Stelle gezogen habe.
    So funktioniert es jetzt erstmal!



  • also, ich hab jetzt das service pack 1 für die ide, sp3 fürn rechner.
    neues projekt erstellt - zack - wieder das gleiche in grün. ich mag die neustarts heute gar nicht mehr zählen. es friert beim debuggen weiterhin gnadenlos der ganze rechner fest, obwohl die kompilierte debugversion keine zicken macht.
    könnte es etwas mit dem debuggen eines mit _beginthread erstellten threads zu tun haben? den erzeuge ich nämlich in der WinMain.c nach der erstellung des hauptfensters mit createwindowsex und vor dem eintritt in die GetMessage schleife. in der WndProc erzeuge ich noch zwei rich-edit-control bei der WM_CREATE nachricht. tja, ich befürchte ja schon fast 😃 , ich habe was verbockt, aber was? wie gesagt, der start ohne debuggen funzt eins-a.



  • moin,
    ich habe jetzt LIBCMTD.LIB zur linker-befehlszeile hinzugefügt und schon 3 mal ohne absturz debugt. kann es sein, das dieser eintrag nun alles wieder gut werden lies?

    mfg.



  • vergiss es! zu früh gefreut, alles beim alten, alles für die kloschüssel - hasta la vista baby 👎



  • ok, hat sich erledigt. hatte wohl zuviel pfusch im code.
    gruß,
    v. n.



  • pnoom schrieb:

    Sind da schwebende Fenster im Spiel? Ist ein bekanntes Problem:..

    Seit kurzem gibts auch nen Bugfix dazu: KB960075



  • also, doch nicht alles ok. hab jetzt alles rausgeworfen, bis auf einen thread. der wird in winmain gestartet. sobald ich mit dem debugger in den thread hüpfen will, ist alles eingefroren. 👎 😡



  • verdammte floating windows



  • selbst wenn die fenster nicht am floaten sind, ist schicht im schacht. ganz toll.



  • wie soll mann den da venünftig software verwickeln 😕



  • vc n00b schrieb:

    also, doch nicht alles ok. hab jetzt alles rausgeworfen, bis auf einen thread. der wird in winmain gestartet. sobald ich mit dem debugger in den thread hüpfen will, ist alles eingefroren. 👎 😡

    Also ich kenne diesen Bug mit den schwebenden Fenstern zwar nicht, aber das hört sich alles irgendwie danach an, dass das nicht (nur?) dein Problem ist. Kannst du das Problem nicht mal isolieren und ein Minimal-Beispiel basteln?

    Wenn du von Threads redest: du erzeugst nicht zufällig einen oder mehrere Threads mit Realtime-Priorität, die deine CPU komplett auslasten oder sowas böses?



  • Talla schrieb:

    pnoom schrieb:

    Sind da schwebende Fenster im Spiel? Ist ein bekanntes Problem:..

    Seit kurzem gibts auch nen Bugfix dazu: KB960075

    Und gibts diesen Hotfix auch für die 2005er ?

    Die da ist nur fürs 2008er !
    Und ja, ich habe dasselbe Problem bei meinem VS2005.



  • R3dNeXX schrieb:

    Talla schrieb:

    pnoom schrieb:

    Sind da schwebende Fenster im Spiel? Ist ein bekanntes Problem:..

    Seit kurzem gibts auch nen Bugfix dazu: KB960075

    Und gibts diesen Hotfix auch für die 2005er ?

    Die da ist nur fürs 2008er !
    Und ja, ich habe dasselbe Problem bei meinem VS2005.

    Ja. Hotfix für das 2005er VS ist die Installation von VS2008 plus KB960075 :p


Log in to reply