Kleines Problem mit TSplitter



  • Hallo,
    ich habe ein kleines Testprogramm gemacht, wo der Splitter mit zwei Memos funktioniert.

    Jetzt habe ich genau diese drei Komponenten in mein eigentliches Programm kopiert und auf einmal ist es nicht mehr möglich, die Größen der beiden Memos mit dem Splitter zu verändern.

    Ich gucke schon die ganze Zeit nach etwas, an meinem Programm, was dies verhindern könnte, mir fällt aber nichts mehr ein..

    Bitte um Rat.

    Grüße,
    halloei



  • Wie hast Du die Memos und Splitter denn angeordnet? Wie hast Du die Eigenschaft Align gesetzt? In meinem BCB6 geht das problemlos. Bei drei Memos nebeneinander zB: Linkes Memo auf alLeft, linker Splitter auf alLeft, rechtes Memo auf alRight, rechter Splitter auf alRight, mittleres Memo auf alClient. In genau dieser Reihenfolge einstellen.

    Grüße Joe



  • Memo1->Align->alTop
    Splitter1->Align->alTop
    Memo2->Align->alClient

    ..das Komische ist halt, dass die gleichen Komponenten (habe sie ja kopiert) in dem Testprojekt laufen, aber in mein derzeitiges Projekt eingefügt, nicht mehr..



  • Ok, nur zwei Memos und ein Splitter, na ja ergibt auch drei... 😉

    Das sollte so aber auch funktionieren. Und Du hast die Komponenten auch tatsächlich in dieser Reihenfolge eingefügt und auch die Align-Eigenschaft jeweils sofort gesetzt? Prüf mal, ob der Splitter nicht aus Versehen nach ganz oben oder unten verrutscht ist. Oder eine der Komponenten deaktiviert ist (Enable = false).

    Grüße Joe



  • Ja, sind alle richtig eingefügt und auch alle enabled.

    Daran, dass ich die Größe der Komponenten anpasse, wenn man die Formgröße zur Laufzeit ändert oder so, liegt das auch nicht (habe mal einiges auskommentiert).

    Es ist so, dass wenn man sich den Splitter "packt", kann man ihn normal hoch und runter ziehen, aber sobald man ihn loslässt, springt er wieder an seine ursprüngliche Position zurück..



  • Das lässt mich vermuten, Du hast Constraints gesetzt, die die Größenänderung verhindern.

    Grüße Joe (der jetzt ernsthaft in Erwägung zieht, sich einzuloggen)



  • ..ich bin doch nicht verrückt.
    Ich hatte lediglich Constraints für die Form gesetzt, aber ohne diese funktioniert es immer noch nicht.
    Kann doch nicht wahr sein.. 😞



  • Hallo,
    habe die Lösung nach langer Zeit jetzt gefunden.
    Ich hatte als Hintergrundbild TImages, die mit ihren Events wohl verhindert haben, dass der Splitter richtig funktionierte.
    Danke für die Antworten

    //Edit: Okay, es liegt lediglich daran, dass alle Komponenten (Parent = Form1) auf den Images drauf liegen. Beide sind per SendToBack() nach hinten gesetzt.
    Hat denn nun wer einen Tipp, wie ich den Splitter trotzdem zum Laufen bringen könnte?



  • Packs in ein Panel.



  • Vielen Dank,
    Problem gelöst 🙂

    Grüße, halloei


Log in to reply