evolutionäre algorithmen bibliothek



  • hallo,
    ich hab hier auf http://eodev.sourceforge.net/ eine "bibliothek" herunter geladen und mit visual stuido 2008 geöffnet. So hab dann den ordner src dem compiler bekannt gemacht wo die ganzen includes zu finden sind.
    Hab zusätzlich zu den schon vorhandenen Projekten einen neuen Projekt Ordner geöffnet und dort eine tutorial cpp (FirstRealGA.cpp) datei hinzugefügt um diese zu testen.
    dann dieses versucht im debugmodus zu starten

    dabei kommen folgende fehlermedlungen

    1>------ Erstellen gestartet: Projekt: testeo, Konfiguration: Debug Win32
    ------
    1>Kompilieren...
    1>FirstRealGA.cpp
    1>c:\dokumente und
    einstellungen\ayalp\desktop\eo-1.0.1\tutorial\lesson1\firstrealga.cpp(56)
    : warning C4305: 'Initialisierung': Verkürzung von 'double' in 'const
    float'
    1>Verknüpfen...
    1>FirstRealGA.obj : error LNK2001: Nicht aufgelöstes externes Symbol
    ""class eoRng eo::rng" (?rng@eo@@3VeoRng@@A)".
    1>FirstRealGA.obj : error LNK2001: Nicht aufgelöstes externes Symbol
    ""private: static int const eoRng::N" (?N@eoRng@@0HB)".
    1>C:\Dokumente und
    Einstellungen\user\Desktop\eo-1.0.1\win\Debug\testeo.exe : fatal error
    LNK1120: 2 nicht aufgelöste externe Verweise.
    1>Das Buildprotokoll wurde unter "file://c:\Dokumente und
    Einstellungen\user\Desktop\eo-1.0.1\win\testeo\Debug\BuildLog.htm"
    gespeichert.
    1>testeo - 3 Fehler, 1 Warnung(en)
    ========== Erstellen: 0 erfolgreich, Fehler bei 1, 0 aktuell, 0
    übersprungen ==========
    

    ich weiss noch von alten projekten die ich gemacht habe das die fehlermeldung Nicht aufgelöstes externes Symbol oft durch methoden entstanden sind in cpp dateien die in meinen headern nicht definiert waren , weil ich vergessen hatte die da anzugeben.

    aber hier ist das glaube ich nicht der selbe fehler.
    hab auch versucht die einzigen bibliotheken *.lib sind vier stück die im
    C:\Dokumente und Einstellungen\user\Desktop\eo-1.0.1\win\lib\DEBUG sind durch

    #pragma comment (lib, "eoga.lib")
    #pragma comment (lib, "eoes.lib")
    #pragma comment (lib, "eoga.lib")
    //#pragma comment (lib, "eoutilsd.lib")
    

    bekannt zu machen , bekannt machung hat funktioniert , musste noch in den projekteinstellungen den pfad dahin angeben. allerdings ändert sich nichts an der fehlermeldung. nur wenn ich

    #pragma comment (lib, "eoutilsd.lib")
    

    diese noch hinzufüge dann kommen noch mehr fehlermeldeungen aufgrund con mehrfach definitionenn oder so ähnlich.

    hoffe mir kann jemand helfen
    viele
    grüsse
    mogli3


Log in to reply