Problem mit wxWindow::SetScrollPos



  • hallo nochmal =),

    kleine Frage zwischendurch nochmal, ist es normal dass wenn ich SetScrollPos (von wxWindow) mit meiner ListCtrl aufrufe, dass diese mir zar den Slider setzt, jedoch den sichtbaren Ausschnitt nicht an entsprechende Position setzt(?nicht refreshed?).

    mein Problem ist nur, dass selbst wenn ich refresh explizit aufrufe, dies an dem Zustand nichts ändert.

    lg,

    scythe.

    und danke im voraus ūü§°



  • ...:( keiner ne idee?
    ich hab auch noch keinen lösungsweg gefunden, geschweige denn eine andere umsetzungsmöglichkeit...



  • die Doku von wxWindow::SetScrollPos sagt folgendes :

    This function does not directly affect the contents of the window: it is up to the application to take note of scrollbar attributes and redraw contents accordingly.

    Da SetScrollPos nicht in der Doku von der wxListCtrl auftaucht, wird es auch nicht unterst√ľtzt ‚ě° andere Weise tun

    Ich wette du findest in der Doku von wxListCtrl das was du brauchst.



  • hmja... hab ich auch gelesen, hab gedacht des kann umgangen werden wenn ma extra noch ma nen refresh aufruft... was nich der fall war... naja,

    falls jemand nochma des gleiche problem haben sollte ich hab die lösung gefunden

    wxListCtrl::EnsureVisible

    is zwar nich ganz des was ich mir vorgestellt habe, da es nur daf√ľr sorgt, das das element im angezeigten bereich ist und nicht gleich an erster stelle aber es erf√ľllt seinen zweck

    dennoch find ich da die wxWidgets doku iwie n bisschen unverständlich... bis ma da drauf kommt was des bewirken soll... vor allem beschreibung:

    wxListCtrl::EnsureVisible

    bool EnsureVisible(long item)

    Ensures this item is visible.

    naja egal... könnt ihr auf gelöst setzen...

    (danke an alle die mal reingeschaut haben)


Log in to reply