"Unable to start debugging"



  • Hallo miteinander,

    mein Visual Studio 2008 zickt neuerdings rum.. und ich weiß nicht wieso.

    Sobald ich mein Programm debuggen will, krieg ich nur ein Fenster in dem nichts weiter außer "Unable to start debugging" steht.
    Ich habe dieses Programm von VS6.0 auf VS2008 portiert um mir die Programmierarbeit zu erleichtern und nun kann ich es nicht einmal mehr ausführen..

    Andere Programme lassen sich einwandfrei debuggen. Habe auch schon einen anderen Rechner hergenommen und es dort ausprobiert: Selbes Spielchen.
    Ich vermute ja fast, dass irgendwas mit den Projekteigenschaften nicht stimmt, sicher bin ich mir da aber nicht. Außerdem hab ich da bisweilen keinen Fehler entdeckt.
    Liegts vielleicht doch an was anderem? Hat von Euch jemand einen Lösungsvorschlag für mich? Würde mich sehr darüber freuen! 🙂

    Grüßle



  • Hast du schonmal das Projekt bereinigt/neu erstellt? Hast du die ncb-Datei mal gelöscht?



  • Gerade ausprobiert.

    ncb gelöscht und nochmal neu compilieren lassen nachdem ich gesäubert habe. Fehler tritt immernoch auf :|


  • Mod

    Läuft das Programm denn überhaupt?
    Wenn nicht, schmeiß mal DEPENDS an.



  • Unter VS6.0 läuft die Software tadellos, aber unter VS2008 kriege ich die besagte Fehlermeldung und es tut sich nichts weiter.



  • DarthWaldee schrieb:

    Unter VS6.0 läuft die Software tadellos, aber unter VS2008 kriege ich die besagte Fehlermeldung und es tut sich nichts weiter.

    Aber kannst du das Projekt erstellen und z.B. ohne IDE starten?



  • Das Problem hat sich gelöst.

    Ich habe das alte Projekt nochmal neu portiert, die entstanden Fehler beseitigt und voila: es startet nun.

    Allerdings krieg ich jetzt eine neue Fehlermeldung, die mit dem Modul "COptionTree" von CodeProject zusammenhängt. Das ist aber ne andere Geschichte.

    Aber vielleicht kennt ja jemand diesen Fehler:

    In der Methode:

    long COptionTreeItem::DrawItem(CDC *pDC, const RECT &rcRect, long x, long y)
    

    tritt das Problem auf, dass das Objekt "pDC" wohl nichts zum "zeichnen" hat..

    Mein Programm stürzt mit nem Debug Assertion Failed ab und verweist mich auf die afwin1.inl, Zeile 666

    VERIFY(::GetTextExtentPoint32(m_hAttribDC, lpszString, nCount, &size));
    

    Bei "m_hAttribDC" steht dann "unused = CXX0030: Error: expression cannot be evaluated".

    Versteh ich das richtig, dass es sich um eine Null Pointer Exception handelt?

    Grüßle
    DarthWaldee


  • Mod

    Was für ein Fehller auftritt sagt der erste Dialog der erscheint.
    Was Du uns hier sagst heißt nur, dass der Debugger die Variable nicht anzeigen kann.



  • *Debug Assertion Failed

    Program: u:\...\MyProgram.exe
    File: f:\dd\vctools\vc7libs\ship\atlmfc\include\afxwin1.inl
    Line: 666

    For informationen... blabla
    *
    Laufwerk "f" existiert bei mir gar nicht. Außerdem sieht es so aus als versuche MFC eine ältere Version von afxwin verwenden zu wollen.. Das Ganze verwirrt mich ganz schön.

    Ich hab mir Depends, bzw. den Depency Walker runtergeladen und meine "MyProgram.exe" geöffnet. Nun kriege ich da die Fehlermeldung, dass es einen error gab und die xerces dll (die ich verwende) nicht im Debugordner gefunden wird. Dabei hatte ich Sie bereits dort reinkopiert! Der Name ist korrekt geschrieben (mehrfach überprüft).


Log in to reply