[Qt] Qt 4.7.2 installation



  • Guten Abend,
    ich versuche schon den ganzen Tag Qt zu installieren
    aber es klappt nicht.

    Ich benutze VS 2008 und habe dazu das SP und SDK installiert.

    Wenn ich nun der Anleitung (http://doc.qt.nokia.com/latest/install-win.html)
    folge, kommt bei mir ab dem Punkt:

    configure -platform win32-msvc2008

    die Fehlermeldung das er "nmake" nicht finden kann.

    nmake.exe finde ich auf meinen System nur in Visual Studio im
    Unterordner bin. Nun hab ich den Pfad bei PATH auch mal eingegeben
    und hab allerdings noch das selbe Problem.

    Welche Tools sollte man denn eigl. alle bei PATH angeben?

    MfG, Benjamin



  • Entweder installieren die Leute das komplette SDK samt Creator und wundern sich, dass VS Probleme beim Kompilieren macht (das SDK kommt mit MinGW), oder es wird für VS selber kompiliert.

    Es gibt aber bereits ein fertiges Paket für VS2008!
    qt.nokia.com -> Download -> LGPL -> Qt libraries 4.7.2 for Windows (VS 2008, 218 MB)
    Link zeigt bereits auf den korrekten download für 4.7.2. Da es immer wieder Updates gibt, solltest du aber wissen, wie man da hin kommt (für die nächsten male).

    Es gibt dann auch noch die Visual Studio Qt Integration, ist aber ein separates Paket, Google hilft.



  • Es hat sich herausgestellt, dass ich soweit
    alles richtig heruntergeladen und installiert habe.

    Anscheinend war die vsinstalldier variable nicht gestetzt.
    Daher musste ich die entsprechende batch Datei umschreiben.
    Falls jemand ein ähnliches Problem hat:
    http://extended64.com/blogs/news/archive/2008/04/18/pros-and-cons-of-shared-compilers-in-win-sdk-and-vs2008.aspx (Problem 1)

    Leider Funktioniet es immer noch nicht, obwohl es heißt:

    "Setting environment for using Microsoft Visual Studio 2008 x86 tools."
    

    .

    Der Fehler:

    NMAKE: fatal error U1077: ""C:\Programme\Microsoft Visual Studio 9.0\VC\BIN\cl.exe"": Rückgabe-Code "0xc0000135"
    

    Im Internet heist es wenn dieser Fehler erscheint, sind die Umgebungsvariablen
    falsch gesetzt. Eigentlich dachte ich, dass das Problem erledigt sei....

    Mein Visual Studio befindet sich auch nicht in "C:\Programme" sondern in "C:\Program Files", allerdings ist mir schon oft in Windows Vista aufgefallen das dies öfters vertauscht wird und letztenendes alles in C:\Program Files landed.

    Ich bin wirklich sehr dankbar für jede Hilfe die ich bekomme.

    MfG, Benjamin



  • Es ist schon lange her das ich das gemacht habe, aber ich kann mich da an was erinnern, dass die configure file in Qt4.7.2/qt ordner liegt.

    Bitte nicht Böse sein wenn ich Quatsch erzähle, soll nur ein kleiner Hinweise sein.



  • So, letzten Endes hat es heute endlich geklappt.
    Mit dieser Anleitung hab ich es geschafft die
    neueste Version von QT zu laufen zu kriegen.

    http://img.di.fct.unl.pt/diogocabral/QT+OF_ProgrammersGuidec++.pdf

    Ich hab dann nur noch in VS 2008 im Menü "Qt" -> "Qt Optionen" den Pfad
    zu dem Qt Ordner angeben müssen, der den Bin und src ordner beinhaltet.

    MfG, Benni


Log in to reply