Qt Versionen mischen



  • Darf man eigentlich libs/dlls der version 4.7.1. mit der 4.7.3 mischen oder gibt es da Probleme?



  • Wieso willst du das machen bzw. wie willst du das denn qmake beibringen? Man kann zB mehrere Versionen im QtCreator eintragen, aber man kann nicht sagen, dass er beim Erstellen mal hier, mal da was nehmen soll...



  • BootLag-BootLag- schrieb:

    Wieso willst du das machen bzw. wie willst du das denn qmake beibringen? Man kann zB mehrere Versionen im QtCreator eintragen, aber man kann nicht sagen, dass er beim Erstellen mal hier, mal da was nehmen soll...

    Ich habe eine DLL und eine LIB sowie eine Header Datei von einem Fremdanbieter. Readme vom Fremdanbieter offenbart Qt 4.7.1, ich dagegen compiliere z.Z. mit der Version 4.7.3. Ob es Sinn macht aus Kompatibilitätsgründen auf 4.7.1 zurückzuweichen?



  • Nya da ich keine präzise Antwort darauf geben kann, kann ich dir nur raten, es versuchen zu kompilieren und dann ein paar mal testen. Wenn es stabil läuft, brauchst du nicht mit der Version runter. Eigentlich gibt es ja nur Probleme, wenn du Dinge aus der 4.7.3 nutzt, die in der 4.7.1 noch nicht waren. Ansonsten steht in der Doku, dass alles abwärtskompatibel ist.


Log in to reply