Meine Builder 2009 spinnt



  • Hallo, jetzt wirds lustig.
    Wenn ich mein Projekt zum Debuggen starte, ist zunächst alles so wie es sein soll. Aber nach einer guten Minute starten nochmal 3 Tasks mit dem selben Programm. Alles was ich bisher unternommen habe, hat in dieser Phase den Builder komplett durcheinandergebracht: halbe Fenster, reaktionsverweigerung und noch anderes seltsammeres. Nur mit brachialen Mitteln war der Builder zu beenden.
    Später habe ich festgestellt, dass nach einer weiteren Minute die drei Tasks sich von alleine beendeten. Von da an liefs wieder korrekt. Ja, ich hab aber keine Tasks programmiert, nur einen Frame.
    Während die 3 Tasks laufen kann ich normal mit meiner Anwendung arbeiten. Debuggen geht aber saulangsam. Ich darf nur nicht versuchen eines der vier Programme zu beenden, denn dann wird es hässlich.
    Ich habe eine ganze zeit nicht mit dem Builder gearbeitet und jetzt ein Projekt mit einer MySQl Datenbank angefangen. Weil es lange nicht funktionierte habe ich Servicepack 2 aufgespielt.
    Kann sich da einer einen Reim machen?
    Gruß Rudi



  • rudiM schrieb:

    Wenn ich mein Projekt zum Debuggen starte, ist zunächst alles so wie es sein soll. Aber nach einer guten Minute starten nochmal 3 Tasks mit dem selben Programm. Alles was ich bisher unternommen habe, hat in dieser Phase den Builder komplett durcheinandergebracht: halbe Fenster, reaktionsverweigerung und noch anderes seltsammeres. Nur mit brachialen Mitteln war der Builder zu beenden.
    Später habe ich festgestellt, dass nach einer weiteren Minute die drei Tasks sich von alleine beendeten. Von da an liefs wieder korrekt. Ja, ich hab aber keine Tasks programmiert, nur einen Frame.

    Was ist ein Task? Ein Thread, ein Prozeß, ganz was anderes?

    rudiM schrieb:

    Ich darf nur nicht versuchen eines der vier Programme zu beenden, denn dann wird es hässlich.

    Das bedeutet konkret?

    rudiM schrieb:

    Ich habe eine ganze zeit nicht mit dem Builder gearbeitet und jetzt ein Projekt mit einer MySQl Datenbank angefangen. Weil es lange nicht funktionierte habe ich Servicepack 2 aufgespielt.

    Service Pack 2 für was? Windows XP? Vista? Oder ein C++Builder-Update oder -Hotfix?

    rudiM schrieb:

    Kann sich da einer einen Reim machen?

    Wenn du es mit der Nomenklatur mal ein bißchen genauer nimmst, vielleicht schon. Momentan sind es noch zu viele offene Fragen.



  • Hallo, ich hab einfach mal mein Herz ausgeschüttet....

    1. Thread natürlich ( Woher ich herkomme hieß das Task )

    Thread-Start: Thread-ID: 1424. Prozess LadebSys.exe (3028)
    Prozessstart: D:\Laden\Sys\Erfassen\Debug\LadebSys.exe. Basisadresse: $00400000. Prozess LadebSys.exe (3028)
    Modul laden: LadebSys.exe. Enthält Debug-Infos. Basisadresse: $00400000. Prozess LadebSys.exe (3028)
    .........
    Modul laden: WINRNR.dll. Ohne Debug-Infos. Basisadresse: $74860000. Prozess LadebSys.exe (3028)
    Modul laden: NAPINSP.dll. Ohne Debug-Infos. Basisadresse: $74850000. Prozess LadebSys.exe (3028)
    Thread-Start: Thread-ID: 3004. Prozess LadebSys.exe (3028)
    Modul laden: PNRPNSP.dll. Ohne Debug-Infos. Basisadresse: $74830000. Prozess LadebSys.exe (3028)
    Modul laden: rasadhlp.dll. Ohne Debug-Infos. Basisadresse: $740D0000. Prozess LadebSys.exe (3028)
    Modul laden: WSHTCPIP.dll. Ohne Debug-Infos. Basisadresse: $740C0000. Prozess LadebSys.exe (3028)
    Modul laden: WSHIP6.dll. Ohne Debug-Infos. Basisadresse: $74700000. Prozess LadebSys.exe (3028)
    Modul laden: IPHLPAPI.DLL. Ohne Debug-Infos. Basisadresse: $73630000. Prozess LadebSys.exe (3028)
    Modul laden: WINNSI.DLL. Ohne Debug-Infos. Basisadresse: $73810000. Prozess LadebSys.exe (3028)
    Thread-Start: Thread-ID: 1776. Prozess LadebSys.exe (3028)
    Thread-Start: Thread-ID: 732. Prozess LadebSys.exe (3028)
    Modul laden: fwpuclnt.dll. Ohne Debug-Infos. Basisadresse: $740E0000. Prozess LadebSys.exe (3028)
    Modul laden: ole32.dll. Ohne Debug-Infos. Basisadresse: $03750000. Prozess LadebSys.exe (3028)
    Modul entladen: ole32.dll. Prozess LadebSys.exe (3028)
    Modul laden: dwmapi.dll. Ohne Debug-Infos. Basisadresse: $72EE0000. Prozess LadebSys.exe (3028)
    Thread-Start: Thread-ID: 1332. Prozess LadebSys.exe (3028)
    Thread-Ende: Thread-ID: 732. Prozess LadebSys.exe (3028)
    Thread-Ende: Thread-ID: 1332. Prozess LadebSys.exe (3028)
    

    2. Das ist wohl seltsam

    Alles was ich bisher unternommen habe, hat in dieser Phase den Builder komplett durcheinandergebracht: halbe Fenster, reaktionsverweigerung und noch anderes seltsammeres. Nur mit brachialen Mitteln war der Builder zu beenden, denn er reagierte auf kein Kommando mehr

    3. Für mich war es klar, dass die Updates für den Builder gemeint waren.
    ich hab Update 2 installiert. Ich war der Meinung Uptade 1 schon vor Jahren installiert zu haben. Ich würd' ja das ganze neu aufspielen, da ich jedoch Offline bin, gibts wieder Ärger mit der Freischaltung.

    Obwohl anscheinend das Programm noch dreimal gestartet wird, erschienen in der Windows-Taskleiste nur ein Icon. Das lies sich jedoch auch nicht stoppen.
    Manchmal verschwindet auch mein Ereignisprotokollfenter und erscheint je nach lust und laune ohne mein zutun. Und es passieren noch ein paar andere Dinge, die schwer zu beschreiben sind.

    Gruß Rudi


Log in to reply