XE6 Boost Meldung "Unknow compiler version..."



  • Hallo zusammen,

    sobald ich mit dem XE6 memory einbinde, oder etwas von Boost, bekomme ich immer die Meldung,

    Unknown compiler version - please run the configure tests and report the results
    

    Ich habe dies nun bis in die Datei codegear.hpp (C:\Program Files (x86)\Embarcadero\Studio\14.0\include\boost_1_39\boost\config\compiler\codegear.hpp) zurück verfolgt.

    Hier scheint mal wieder die Compilerversion nicht richtig eingetragen zu sein, da bei mir __CODEGEARC__ = 0x0680 ist.

    // versions check:
    #if (__CODEGEARC__ > 0x66F)
    #  if defined(BOOST_ASSERT_CONFIG)
    #     error "Unknown compiler version - please run the configure tests and report the results"
    #  else
    #     pragma message( "Unknown compiler version - please run the configure tests and report the results")
    #  endif
    #endif
    

    Bin ich der einzige mit dem Problem, hab mit Google nämlich nichts für den XE6 gefunden.
    Kann ich den Vergleich einfach anpassen, oder sollte noch mehr verändert werden?

    MfG Stephan



  • Also, ich benutze sowohl boost als auch std und habe dieses Problem nicht und auch noch nie gehabt.

    Ich benutze ebenfalls XE6.
    😕 😕



  • Burkhi schrieb:

    Also, ich benutze sowohl boost als auch std und habe dieses Problem nicht und auch noch nie gehabt.

    Ich benutze ebenfalls XE6.
    😕 😕

    Das ist interessant 😕
    Kannst Du bitte mal den entsprechenden Abschnitt deiner Headerdatei posten?

    MfG Stephan



  • // versions check:
    #if (__CODEGEARC__ > 0x66F)
    #  if defined(BOOST_ASSERT_CONFIG)
    #     error "Unknown compiler version - please run the configure tests and report the results"
    #  else
    #     pragma message( "Unknown compiler version - please run the configure tests and report the results")
    #  endif
    #endif
    

    Sieht m.E. komplett identisch aus zu dem, was du gepostet hast.


Log in to reply