gnome-terminal und ist sofort weg



  • Mein Betriebsystem ist Ubuntu 14.04.1 (64 Bit), Desktopumgebung gnome.

    Ich habe ein Problem mit dem Terminal und Scrippt.

    Wenn ich ein Script (Script.sh) folgendermassen in gedit editiere/programmiere>>

    #!/bin/sh
    echo " Dies ist ein Output"

    Und dann abspeichere, und ausführbar mache.

    Und auf dem Desktop draufklicke, dann startet das gnome-terminal und ist sofort weg.

    Ich möchte aber das das Terminal auf dem Monitor erhalten bleibt, und eingaben im Anschluss zum Scriptdurchlauf annimmt.

    Wie ist das zu bewerkstelligen?

    Muss ich die bash.rc editieren, und wenn ja wie?



  • Mister C++ schrieb:

    #!/bin/sh
    echo " Dies ist ein Output"

    So

    #!/bin/sh
    echo " Dies ist ein Output"
    read
    


  • read
    

    Ah du hast recht durch den Input (read) ist das Terminal für die Eingabe gespeert.
    Trotzdem zufrieden bin ich mit der Lösung nicht, weil geändert hat es nichts .
    Ohne irgendeine Eingabe (z.B Tastatur) meinerseits, taucht das gnome Terminal ganz kurz auf und verschwindet sofort wieder.
    Wenn ich das Scrippt in ein offenes gnome terminal ineinziehe dann kommt folgende Fehlermeldung

    '/home/internet/Schreibtisch/Unbenanntes Dokument 2.sh'
    Dies ist ein Output
    /home/internet/Schreibtisch/Unbenanntes Dokument 2.sh: 3: read: arg count



  • Ich dachte eher in Richtung

    olwaysopen??



  • Mister C++ schrieb:

    read
    

    Ah du hast recht durch den Input (read) ist das Terminal für die Eingabe gespeert.
    Trotzdem zufrieden bin ich mit der Lösung nicht, weil geändert hat es nichts .
    Ohne irgendeine Eingabe (z.B Tastatur) meinerseits, taucht das gnome Terminal ganz kurz auf und verschwindet sofort wieder.
    Wenn ich das Scrippt in ein offenes gnome terminal ineinziehe dann kommt folgende Fehlermeldung

    '/home/internet/Schreibtisch/Unbenanntes Dokument 2.sh'
    Dies ist ein Output
    /home/internet/Schreibtisch/Unbenanntes Dokument 2.sh: 3: read: arg count

    Ach ja - Du hast ja Ubuntu. Da ist die bash nicht die Standardshell. Dann mach:

    read a
    

    So eine Option gibt es nicht. Ein Terminalfenster führt ein Programm aus und wenn das Programm fertig ist, dann wird das Terminal beendet.



  • read a

    Jetzt ist es fast richtig es wird gewartet bis ein Input erfolgt, trotzdem ist da nicht die gesuchte Lösung.
    Weil ich suche ein alwaysopen Lösung, also immer offen Lösung. Eventuell in bash.rc einzutragen.



  • Das kann deine Shell nicht, weil sie nichts von Fenstern weiß, auch nichts von denen deines Terminalemulators.

    IIRC hat gnome-terminal aber ohnehin auch eine Config-Option für das von dir gewünschte "Halte das Fenster offen"-Verhalten.



  • Ja, gibt es.

    Profiles/Profile Preferences/Title and Command:

    When command exits: Hold the terminal open



  • Dieser Thread wurde von Moderator/in nman aus dem Forum Linux/Unix in das Forum Themen rund um die IT verschoben.

    Im Zweifelsfall bitte auch folgende Hinweise beachten:
    C/C++ Forum :: FAQ - Sonstiges :: Wohin mit meiner Frage?

    Dieses Posting wurde automatisch erzeugt.



  • Ja, gibt es.

    Profiles/Profile Preferences/Title and Command:

    When command exits: Hold the terminal open

    Wo muss ich das suchen >>>Profiles/Profile Preferences/Title and Command:



  • Nach einigem suchen habe ich es gefunden.
    Neues Profil >>> Profilname>>>Basierend auf >> Anlegen
    Profil bearbeiten >>> Titel und Befehl >>> Wenn befehl beendet

    > Das Terminal geöffnet halten

    Kann man das irgendwie automatisieren, also per gsettings??



  • Mister C++ schrieb:

    Kann man das irgendwie automatisieren, also per gsettings??

    Warum automatisieren? Das stellst du einmal ein und es bleibt aktiv.



  • Warum automatisieren? Das stellst du einmal ein und es bleibt aktiv.

    Das Terminal dient zum automatisieren.
    Für mich aus Bequemlichkeit, und weil es meistens im Terminal schneller geht.
    Fehler sind solange im Script keine sind, weitesgehend ausgeschlossen.
    Immer wiederkehrende Bedienschritte erledigt man im Terminal.



  • 😕

    Das war keine Antwort auf meine Frage. Du brauchst das doch nur einmal zu aktivieren und dann ist es aktiv.

    Klar kannst du das irgendwie mit gsettings oä. machen, aber den passenden Key musst du dir schon selbst heraussuchen.


Log in to reply