Ausgewählte Bilder an Photo Viewer



  • Guten Abend!

    Ich versuche grad Bilder im Photo Viewer anzeigen zu lassen.

    private void btnPictureViewer_Click(object sender, EventArgs e)
            {
                ProcessStartInfo startInfo = new ProcessStartInfo(@"C:\Windows\System32\rundll32.exe", "\"C:\\Program Files (x86)\\Windows Photo Viewer\\PhotoViewer.dll\", ImageView_Fullscreen C:\\Bild1.jpg");
                startInfo = new ProcessStartInfo(@"C:\Windows\System32\rundll32.exe", "\"C:\\Program Files (x86)\\Windows Photo Viewer\\PhotoViewer.dll\", ImageView_Fullscreen C:\\Bild2.jpg");
                Process.Start(startInfo);
            }
    

    Klappt soweit auch ganz gut.
    Allerdings möchte ich, dass nur die Bilder, die ich auch im Code angebe (Bild1 + Bild2) angezeigt werden.
    Liegen jedoch mehrere Bilddateien in C: dann werden alle vorhandenen angezeigt (wenn ich z.B. mit der Pfeiltaste im Viewer durchklicke).

    Ich hoffe, es ist soweit verständlich, was ich gerne möchte?!
    Muss ich die Bilder anderst abrufen oder anderst anbinden? 😕

    Hoffe auf Eure Hilfe - danke!



  • Die Lösung ist doch wohl offensichtlich: dann mußt du die Bilder in einem eigenen Ordner ablegen.

    Und statt den hartkodierten Pfaden solltest du besser die Umgebungsvariablen nutzen, s. Environment.GetFolderPath(...) - und die Pfade dann mit Path.Combine(...) zusammensetzen.

    PS: "C:\" ist ja wohl ein selten schlechter Ort für eigene Dateien...

    PPS: Warum initialisierst du zweimal die Variable startInfo? 😕



  • Die Lösung ist doch wohl offensichtlich: dann mußt du die Bilder in einem eigenen Ordner ablegen.

    Genau das wollte ich wissen, ob ich dies nicht einfach durch das Übergeben des Bildnamens steuern kann?

    Und statt den hartkodierten Pfaden solltest du besser die Umgebungsvariablen nutzen, s. Environment.GetFolderPath(...) - und die Pfade dann mit Path.Combine(...) zusammensetzen.

    Danke für den Tipp!

    PS: "C:\" ist ja wohl ein selten schlechter Ort für eigene Dateien...

    Stimme ich dir zu - war nur zum Testen, ob die Anbindung überhaupt klappt


Log in to reply