Winbind haengt sich bei Userlogin auf



  • Hallo,

    ich habe folgende, etwas seltsame Konfiguration:
    1x Debian als PDC mit Samba und nocheinmal Debian als Samba-Member mit XRDP darauf installiert.
    Ziel soll am Ende sein, dass sich die Benutzer ueber mstsc mit ihren Domain-Login-Daten anmelden koennen.
    Die Benutzer und Gruppen werden alle korrekt bei wbinfo -u/g aufgelistet und auch getent passwd/group zeigt ihre lokalen Spiegel mit Domainpraefix korrekt an. Versuche ich mich allerdings mit einem dieser Nutzer einzuloggen, sei es ueber XRDP oder ueber ssh, haengt sich Winbind komplett auf. wbinfo -u/g listet nichts mehr auf und kann nur mit Strg+C beendet werden, selbst ein ls -la auf das Home-Directory des entsprechenden Users haengt sich auf, vermutlich weil es versucht, die Benutzer- und Gruppennamen abzurufen. Bei getent laufen die lokalen Benutzer durch, aber sobald der erste Domain User erscheinen wuerde, haengt wieder alles.
    Benutze ich als root su um mich als einer dieser Nutzer zu impersonieren, so funktioniert alles tadellos.
    Winbind neustarten bringt auch nichts, es haengt zwar nichts mehr, aber wibinfo -u/g meint nur noch 'Error looking up users'. Die Winbind-Logs geben aber umgekehrt auch nichts her, als wuerde sich das Ding einfach ohne einen Mucks in die Unresponsivitaet schiessen.

    Hat irgendjemand grundlegend eine Idee, woran das liegen koennte? Samba-Config usw. kann ich alles gerne noch nachreichen, wenn es was bringt, aber ich bin mir bisweilen nicht sicher, ob man das Problem dort suchen kann.

    Ich waere fuer jeden Denkanstoss dankbar.


Log in to reply