Math processing error


  • Mod

    Hallo,

    ich bekomme in letzter Zeit manchmal ein rotes "[Math processing error]", da wo LaTeX-Tags stehen. Den Threads im Matheforum zu urteilen, bin ich damit nicht der einzige Betroffene. Da der Fehler nicht deterministisch auftritt, kann ich leider nur wenig Zusatzinformation geben, da ich nicht mit dem Fehler experimentieren kann. Der Inhalt der Tags ist auf jeden Fall korrekt. Nach einer Weile (~Minuten) verschwindet der Fehler beim Neuladen der Seite von alleine. Ich habe den Fehler bisher nur beim Firefox beobachtet, aber das liegt da dran, dass ich nur den Firefox benutzt habe. Das ist leider alles, was ich bisher herausfinden konnte.



  • Habe das selbe auch mit Chromium beobachten können, würde daher den Browser als Ursache erstmal ausschließen.



  • Könnte aber eine Betriebssystemgeschichte sein (Updates o.ä).


  • Mod

    nachtfeuer schrieb:

    Könnte aber eine Betriebssystemgeschichte sein (Updates o.ä).

    Hab's unter gänzlich verschiedenen Systemen beobachtet.


  • Administrator

    Schwer zu sagen, woran das liegt. Wir verwenden MathJax und diesbezüglich immer die letzte Version, welche über ihren CDN angeboten wird. Wenn man nach dem Fehler im Internet sucht, findet man tausende von Fällen über alle Jahre verteilt.

    Vielleicht sind es auch fehlerhafte Releases, die dann wieder ersetzt werden? Keine Ahnung.



  • Ja, ich hatte das in den letzten Tagen auch ständig (Firefox, Windows X).



  • Foreneinträge weisen auf einen Konflikt zwischen HTTP und HTTPS hin. Empfohlen wird lokales Speichern der Bilddateien (als Workaround) u.a.
    http://stackoverflow.com/questions/28330413/can-mathjax-be-used-with-https


  • Administrator

    nachtfeuer schrieb:

    Foreneinträge weisen auf einen Konflikt zwischen HTTP und HTTPS hin. Empfohlen wird lokales Speichern der Bilddateien (als Workaround) u.a.
    http://stackoverflow.com/questions/28330413/can-mathjax-be-used-with-https

    Sollte kein Problem sein, wir laden es über eine relative URL:

    <script type="text/javascript" src="//cdn.mathjax.org/mathjax/latest/MathJax.js?config=TeX-AMS-MML_HTMLorMML"></script>
    

  • Mod

    Mal angenommen, ich beobachte den Fehler erneut: Was wären die nützlichsten Tests, die ich durchführen könnte? Ich kenne mich mit Webtechniken nicht so gut aus, daher wäre es gut zu wissen, wie ich bei der Analyse helfen kann.



  • SeppJ schrieb:

    Mal angenommen, ich beobachte den Fehler erneut: Was wären die nützlichsten Tests, die ich durchführen könnte? Ich kenne mich mit Webtechniken nicht so gut aus, daher wäre es gut zu wissen, wie ich bei der Analyse helfen kann.

    naja, groß analysieren...
    Am einfachsten zu testen geht es mit direktem Browservergleich, zumindest unter Windows.
    Ich mach das so: surften tu ich mit Opera, und wenn größere Probleme auftauchen, gucke ich, ob der (Windows) Internet Explorer auch Probleme hat (bei relativ offener Einstellung und ohne Zusätze)(notfalls auf einem anderen Benutzerkonto.)
    Wenn die (Haupt-)Seite selber nicht lädt, noch mal anpingen, das wars.
    (Für schwierige Fälle kann man auch noch links bzw. elinks anwerfen, oder andere Textbrowser.
    Man könnte jetzt noch den DNS-Server switchen, aber da lohnt es sich eher, Suchmaschinen anzuwerfen und erstmal gucken, wie es anderen damit geht.
    Für Schadcodegeschichten: läuft Youtube ordentlich?

    Genauere Analysen? Hier empfehlen sich wohl die Entwicklertools für Chrome, aber Chrome habe ich nicht installiert.
    (vielleicht findet sich noch was brauchbares im Plugin-Zoo für den eigenen Browser.)
    (anderes Benutzerkonto mit Chrome und anderen Diagnosesachen hilfreich)

    Gut wäre noch, die Uhrzeit aufzuschreiben, aber das wäre schon fast zuviel des guten (wie auch process explorer https://technet.microsoft.com/en-us/sysinternals/bb896653.aspx und Co)

    Nein, wichtiger ist vielleicht zu überlegen, ob z.B. KaTex http://www.intmath.com/blog/mathematics/katex-a-new-way-to-display-math-on-the-web-9445 eine brauchbare Alternative wäre (läuft ohne Javascript, schon mal gut)
    oder ob nicht eine library auf cpp direkt möglich wäre.
    (ich hatte schon öfter Probleme bei Mathesymboldarstellungen, aber das war auf dem alten Notebook, und da war das so, dass ich Javascript standardmäßig abgeschaltet hatte, oder andere Opera-Restriktionen. Mit dem Internet Explorer (relativ offen) tauchten keine Probleme auf).


  • Mod

    nachtfeuer schrieb:

    naja, groß analysieren...
    Am einfachsten zu testen geht es mit direktem Browservergleich, zumindest unter Windows.
    Ich mach das so: surften tu ich mit Opera, und wenn größere Probleme auftauchen, gucke ich, ob der (Windows) Internet Explorer auch Probleme hat (bei relativ offener Einstellung und ohne Zusätze)(notfalls auf einem anderen Benutzerkonto.)
    Wenn die (Haupt-)Seite selber nicht lädt, noch mal anpingen, das wars.
    (Für schwierige Fälle kann man auch noch links bzw. elinks anwerfen, oder andere Textbrowser.
    Man könnte jetzt noch den DNS-Server switchen, aber da lohnt es sich eher, Suchmaschinen anzuwerfen und erstmal gucken, wie es anderen damit geht.
    Für Schadcodegeschichten: läuft Youtube ordentlich?

    Ich meine gezielte Analysen, die mir die Verantwortlichen empfehlen würden, da sie eventuell schon einen Verdacht haben. Deine Vorschläge sind ungezieltes Rumstochern, das letztlich wenig bringen wird. Auf die Ideen wäre ich auch von alleine gekommen.



  • SeppJ schrieb:

    Auf die Ideen wäre ich auch von alleine gekommen.

    Bist du aber nicht, sonst hättest du nicht gefragt.


  • Administrator

    Ich habe mal probiert, zusätzliche Informationen dazu zu erhalten. Wie es aussieht, deutet das meistens auf drei mögliche Ursachen hin:

    • Das CDN ist überlastet oder fehlerhaft konfiguriert. Passiert anscheinend gerne mal, wenn neue Versionen herauskommen.
    • Die Version auf dem CDN ist fehlerhaft.
    • Die Version in deinem Cache ist fehlerhaft.

    Vorhandene Lösungen:

    • Warten bis das CDN nicht mehr überlastet ist.
    • Warten bis eine korrigierte Version auf dem CDN liegt.
    • Lokaler Cache leeren, bzw. neu laden.
    • MathJax lokal hosten.

    Wie regelmässig kommt denn dieses "Math Processing Error" vor? Zumindest schätzungsweise?


  • Mod

    Dravere schrieb:

    Wie regelmässig kommt denn dieses "Math Processing Error" vor? Zumindest schätzungsweise?

    Ich habe es bisher zweimal bemerkt, jeweils für ein paar Minuten. Das letzte Mal als ich den Thread erstellte, das andere Mal ein oder zwei Tage vorher.



  • Ich hatte den Fehler eben auch.
    (Windows 10 64 bit + Chrome 48.0.2564.116 m).

    Und wollte mir das mit der JavaScript Console anschauen ... nach einem Neuladen ging alles. Hatte allerdings zwei Fehlermeldungen drin (die beim neuladen leider verschwunden sind - habe sie vergessen zu kopieren ...), dass irgendwelche Elemente (HTML-Container) nicht gefunden wurde.

    Meine Vermutung wäre, dass das LaTeX JavaScript bereits ausgeführt wird, bevor die Website komplett aufgebaut/geladen ist und somit auf null Objekte zugegriffen wird. (Ohne es jetzt näher angeschaut zu haben ...)



  • jb schrieb:

    Und wollte mir das mit der JavaScript Console anschauen ... nach einem Neuladen ging alles.

    War bei mir auch so. Bei mir standen aber keine Fehler drin.


  • Mod

    Jetzt hatte ich gerade, dass gar nichts da stand (leerer Platzhalter), aber nach einem Neuladen ging es.



  • Habe es auch gerade.
    Die Fehlermeldung:
    Uncaught TypeError: Cannot read property 'display' of undefined

    if(l){if(k.HTMLCSS.display){l=l.parentNode}l.parentNode.removeChild(l)}delete k.HTMLCSS},getHD:function(l,m){if(l.bbox&&this.config.noReflows&&!m){return{h:l.bbox.h,d:l.bbox.d}}var k=l.style.position;
    

    Ab .display wird in jax.js ein Fehler angezeigt.


Log in to reply