HTTP(S) Request per Curl



  • Ich versuche grad Curl mit Visual C++ 2013 zu benutzen. Es funktioniert aber nicht.

    Hier der Code:

    #include <iostream>
    #include <stdio.h> 
    #include <curl/curl.h> 
    
    int main(void)
    {
    	CURL *curl;
    	CURLcode res;
    
    	curl = curl_easy_init();
    	if (curl) {
    		curl_easy_setopt(curl, CURLOPT_URL, "http://google.com");
    		res = curl_easy_perform(curl);
    
    		/* always cleanup */
    		curl_easy_cleanup(curl);
    	}
    	return 0;
    }
    

    Ich bekomme immer einen Linkerfehler, da mir die libcurl.lib fehlt. Ich weiß aber nicht, wo ich die finden kann. Auf der offiziellen Homepage habe ich sie nicht gefunden.

    Fehler 1 error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__curl_easy_init" in Funktion "_main". C:\Users\bababa\documents\visual studio 2013\Projects\Projekt2\Projekt2\Quelle.obj Projekt2
    Fehler 2 error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__curl_easy_setopt" in Funktion "_main". C:\Users\bababa\documents\visual studio 2013\Projects\Projekt2\Projekt2\Quelle.obj Projekt2
    Fehler 3 error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__curl_easy_perform" in Funktion "_main". C:\Users\bababa\documents\visual studio 2013\Projects\Projekt2\Projekt2\Quelle.obj Projekt2
    Fehler 4 error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__curl_easy_cleanup" in Funktion "_main". C:\Users\bababa\documents\visual studio 2013\Projects\Projekt2\Projekt2\Quelle.obj Projekt2
    Fehler 5 error LNK1120: 4 nicht aufgelöste Externe C:\Users\bababa\documents\visual studio 2013\Projects\Projekt2\Debug\Projekt2.exe 1 1 Projekt2

    Das ist die Fehlermeldung, die dann erscheint.



  • #pragma comment(lib, "libcurl.lib");
    


  • Fehler 1 error LNK1104: Datei "libcurl.lib" kann nicht geöffnet werden. C:\Users\bababa\documents\visual studio 2013\Projects\Projekt2\Projekt2\LINK Projekt2



  • Vergessen, das Bibliotheksverzeichnis in Linkeroptionen in den Projekteinstellungen hinzuzufügen?



  • habs hingekriegt. war falsch gebuildet. danke



  • Danke nochmal.



  • Cool.



  • Ich versuche es nochmal.


Log in to reply