C++ programm mit c++14 // thread closed



  • hallo habe nur ne kurze fragen
    ich suche ein programm zum codes schreiben wobei der compiler c++14 unterstüzt
    ich habe schon code blocks,visual studio 2017 und dev c++ getestet.
    mir gefällt code blocks am besten.
    allerdings habe ich da das problem dass die <iostream> datei nicht gefunden wird.
    und ich weiß ich nicht genau wie ich c++14 einfüge



  • ReinesWeed schrieb:

    und ich weiß ich nicht genau wie ich c++14 einfüge

    Schonmal Ctrl+V probiert?



  • WeinesReed schrieb:

    ReinesWeed schrieb:

    und ich weiß ich nicht genau wie ich c++14 einfüge

    Schonmal Ctrl+V probiert?

    ist mir etwas sehr ungenau XD



  • Wie kann dir denn Codeblocks zusagen, wenn noch nicht einmal iostream vorhanden ist? Selbst hello world kann man so nicht ausprobieren.
    Für Windows würde ich dir VS 2017 empfehlen, zumindest bis du ein wenig Erfahrung gesammelt hast.



  • manni66 schrieb:

    Wie kann dir denn Codeblocks zusagen, wenn noch nicht einmal iostream vorhanden ist? Selbst hello world kann man so nicht ausprobieren.
    Für Windows würde ich dir VS 2017 empfehlen, zumindest bis du ein wenig Erfahrung gesammelt hast.

    iostream war mal vorhanden.
    dann habe ich mir dass buch "der c++ programmierer" gekauft und die schritte befolgt die extra für codeblocks angegeben sind
    hello world habe ich schon vor dem buch getestet und es ging.
    allerdings weiß ich nicht warum jetzt iostream nicht gefunden wird

    ||=== Build file: "no target" in "no project" (compiler: unknown) ===|
    fatal error: iostream: No such file or directory



  • Schon probiert, neu zu installieren? Alternativ kannst du auch MinGW-w64 manuell runterladen und installieren.



  • Das spricht jetzt auch nicht gerade für Codeblocks. Meine Empfehlung steht. Grundsätzlich ist das hier aber das falsche Forum, du hast ein Problem mit deiner IDE, nicht mit C++.



  • Fytch schrieb:

    Schon probiert, neu zu installieren? Alternativ kannst du auch MinGW-w64 manuell runterladen und installieren.

    codeblocks ja. mingw manuell noch nicht. muss ich auf eine bestimmte version achten ? (wegen c++14)



  • manni66 schrieb:

    Das spricht jetzt auch nicht gerade für Codeblocks. Meine Empfehlung steht. Grundsätzlich ist das hier aber das falsche Forum, du hast ein Problem mit deiner IDE, nicht mit C++.

    sry ist erst mein zweiter beitrag hier auf der seite 🙄



  • ReinesWeed schrieb:

    codeblocks ja. mingw manuell noch nicht. muss ich auf eine bestimmte version achten ? (wegen c++14)

    Ja, sollte mindestens GCC 5 sein, also 5.4, 6.3 oder 7.1. Quelle: https://gcc.gnu.org/projects/cxx-status.html#cxx14



  • Hast du denn ein C++ Projekt erstellt, oder einfach nur eine Datei erstellt, ohne einen Workspace oder wie das auch heißt? C++14 aktivieren geht so:
    [Settings] -> [Compiler] -> [Tab Compiler Settings] -> [Tab Compiler Flags] -> Ankreuzen was du willst, z.B. "Have g++ follow the C++14 ISO C++ language standard [-std=c++14].

    Du kannst die Flags auch "manuell" beim Kompilieren angeben, aber CodeBlocks erledigt das so für dich.



  • Fytch schrieb:

    ReinesWeed schrieb:

    codeblocks ja. mingw manuell noch nicht. muss ich auf eine bestimmte version achten ? (wegen c++14)

    Ja, sollte mindestens GCC 5 sein, also 5.4, 6.3 oder 7.1. Quelle: https://gcc.gnu.org/projects/cxx-status.html#cxx14

    ich hab mir jetzt mingw hier gedownloaded : " https://www.archlinux.org/packages/community/x86_64/mingw-w64-gcc/ "

    nachdem ich die winrar datei geöffnet habe sehe ich :

    usr (ordner) -> bin,i686-w64-mingw32,lib,x86_64-minigw32
    .PKGINFO
    .BUILDINFO
    .MTREE

    weiß jetzt nicht weiter 😕
    würde mich über nen anderen link freuen falls es die sache einfacher macht.
    habe 64bit windows falls es wichtig ist
    wie ich sehe ist mein code blocks auf 32bit version 16.01



  • HarteWare schrieb:

    Hast du denn ein C++ Projekt erstellt, oder einfach nur eine Datei erstellt, ohne einen Workspace oder wie das auch heißt? C++14 aktivieren geht so:
    [Settings] -> [Compiler] -> [Tab Compiler Settings] -> [Tab Compiler Flags] -> Ankreuzen was du willst, z.B. "Have g++ follow the C++14 ISO C++ language standard [-std=c++14].

    Du kannst die Flags auch "manuell" beim Kompilieren angeben, aber CodeBlocks erledigt das so für dich.

    habe es auch so gemacht (wie im buch beschrieben)
    vllt habe ich doch kein problem mit c++14 sonder eher das die datei "iostream" aus welchen grund auch immer nicht gefunden wird 🙄



  • ReinesWeed schrieb:

    ich hab mir jetzt mingw hier gedownloaded : " https://www.archlinux.org/packages/community/x86_64/mingw-w64-gcc/ "

    nachdem ich die winrar datei geöffnet habe sehe ich :

    usr (ordner) -> bin,i686-w64-mingw32,lib,x86_64-minigw32
    .PKGINFO
    .BUILDINFO
    .MTREE

    weiß jetzt nicht weiter 😕
    würde mich über nen anderen link freuen falls es die sache einfacher macht.
    habe 64bit windows falls es wichtig ist
    wie ich sehe ist mein code blocks auf 32bit version 16.01

    Wenn du Windows hast, wieso denkst du dann, es sei eine gute Idee, etwas aus dem Arch User Repository zu laden?
    Das hier ist der Installer, den ich persönlich auf Windows nutze: https://sourceforge.net/projects/mingw-w64/

    EDIT: wähle bei der Installation definitiv posix-Threads und dwarf-Exceptions aus, mit allem anderen hatte ich fürchterlich Probleme...

    LG



  • Fytch schrieb:

    ReinesWeed schrieb:

    ich hab mir jetzt mingw hier gedownloaded : " https://www.archlinux.org/packages/community/x86_64/mingw-w64-gcc/ "

    nachdem ich die winrar datei geöffnet habe sehe ich :

    usr (ordner) -> bin,i686-w64-mingw32,lib,x86_64-minigw32
    .PKGINFO
    .BUILDINFO
    .MTREE

    weiß jetzt nicht weiter 😕
    würde mich über nen anderen link freuen falls es die sache einfacher macht.
    habe 64bit windows falls es wichtig ist
    wie ich sehe ist mein code blocks auf 32bit version 16.01

    Wenn du Windows hast, wieso denkst du dann, es sei eine gute Idee, etwas aus dem Arch User Repository zu laden?
    Das hier ist der Installer, den ich persönlich auf Windows nutze: https://sourceforge.net/projects/mingw-w64/

    EDIT: wähle bei der Installation definitiv posix-Threads und dwarf-Exceptions aus, mit allem anderen hatte ich fürchterlich Probleme...

    LG

    DANKE iostream geht wieder.
    allerdings bekomme ich noch einen error
    ||=== Build file: "no target" in "no project" (compiler: unknown) ===|
    ich glaube danach kann ich endlich weiter mein buch lesen um zu lernen ❤



  • manni66 schrieb:

    Das spricht jetzt auch nicht gerade für Codeblocks. Meine Empfehlung steht. Grundsätzlich ist das hier aber das falsche Forum, du hast ein Problem mit deiner IDE, nicht mit C++.

    nur damit hier kein falscher Eindruck von Codeblocks entsteht:
    ich hab auf Windows immer das Bundle Codeblocks+mingw runtergeladen und installiert. Es hat immer problemlos funktioniert.



  • ||=== Build file: "no target" in "no project" (compiler: unknown) ===|

    Hast du denn ein C++ Projekt erstellt, oder einfach nur eine Datei erstellt, ohne einen Workspace oder wie das auch heißt?

    P.S.: Bin mir nicht sicher ob das ein Fehler ist. Bei meiner CodeBlocks Version spuckt der für die .cpp Datei sogar noch ein Programm aus, auch ohne Projekt. Es sieht dann so aus:

    ||=== Build file: "no target" in "no project" (compiler: unknown) ===|
    ||=== Build finished: 0 error(s), 0 warning(s) (0 minute(s), 0 second(s)) ===|
    


  • HarteWare schrieb:

    ||=== Build file: "no target" in "no project" (compiler: unknown) ===|

    Hast du denn ein C++ Projekt erstellt, oder einfach nur eine Datei erstellt, ohne einen Workspace oder wie das auch heißt?

    P.S.: Bin mir nicht sicher ob das ein Fehler ist. Bei meiner CodeBlocks Version spuckt der für die .cpp Datei sogar noch ein Programm aus, auch ohne Projekt. Es sieht dann so aus:

    ||=== Build file: "no target" in "no project" (compiler: unknown) ===|
    ||=== Build finished: 0 error(s), 0 warning(s) (0 minute(s), 0 second(s)) ===|
    

    P.P.S.: Den <iostream> Fehler habe ich bekommen, als ich die Datei zuerst ausversehen als .c abgespeichert hatte.

    File->New->Projects-> /Files\ -> c/c++ source

    mache ich hier etwas falsch ?
    habs auch so schon leer gespeichert allerdings ändert es bei mir nix :C

    im ordner sieht es einfach wie ein "textdokument" aus
    allerdings ist es vom daten typ eine "CPP-Datei"
    habe auch ein eine datei vom typ "O-Datei"

    EDIT: wenn ich die datei über "Dev-C++ 5.11" starte und compile geht alles ohne probleme. ich habe keine ahnung was los ist >.> ich versuche code blocks nochmal neu zu downloaden

    EDIT2: hat sich leider nix geändetn 😞

    EDIT3: ES GEHT WIEDER. irgend was war mit den code block datein im %appdata% ordner falsch. nachdem ich den ordner gelöscht habe und code blocks nochmal neu gedownloadet habe ging es endlich ❤

    VIELEN DANK AN ALLE DIE MIR GEHOLFEN HABEN 😃

    ------------>thread closed<------------



  • Was du (vermutlich) willst ist:
    File -> New -> Project -> Console Application -> C++ -> Name eingeben -> Finish

    Dann hast du ein neues Codeblocks .cbp Projekt mit einer main.cpp drin. Da kannst du gleich loslegen. Solltest du mal weitere Header/Source Dateien brauchen, kannst du diese einfach hinzufügen.

    LG


Log in to reply