Hilfe bei Bezeichner-Wahl



  • Hallo,

    ich habe einen header, in dem verschiedene geometrische Flächen und Körper definiert sind (Rect, Cube etc) und Funktionen sie zu manipulieren und darzustellen.

    Den habe ich "objects.h" genannt und die Funktionen entsprechend moveObject() etc.
    Es sind auch im Code Objekte.
    Mit dieser Bezeichnung bin ich aber nicht ganz zufrieden, das beißt sich irgendwie in anderen cpp.

    Aber was soll ich nehmen? forms oder bodies? Es sind sie ja beide und moveForm() geht ja, aber moveBody()?
    Oder einfach figures, moveFigure()?



  • körper heißt soweit ich weiß field und fläche heißt area.



  • Finde ich auch nicht richtig passend. moveArea(). Und wenn das Objekt jetzt Cube oder Pyramid ist? Dann müsste es moveField() heißen.

    Und als header-Bezeichnung, areas oder fields?



  • Nach diesem Wörterbuch (http://www.henked.de/maple/woerterbuch.htm#K heißt Körper im geometrischen Sinne solid figure. Die Bezeichnung field habe ich in Zusammenhang mit Geometrie aber auch noch nie mit Körpern verbunden.
    Meine Vorschläge wären sonst noch irgendein Name mit Geometrie, z.B.:
    - Geometric_Objects
    - Geometric_Figures
    - Vllt. auch nur Figures, die Frage ist, ob man in einer Fläche auch eine Figur sieht.

    Das wären so meine Vorschläge, sind vllt. auch eine Anregung.



  • Hmhm, danke. Mit Figure kann ich mich auch gut anfreunden. Durch die header-Bezeichnung weiß man schon ungefähr, was da drin ist und wenn irgendwo im Code etwas wie moveFigure() steht, weiß man auch ungefähr, was das ist. Also besser jetzt als moveObjekt() zb.

    Über den Zusatz 'geometric' muss ich noch nachdenken.



  • Field ist die englische Bezeichnung für die algebraische Struktur Körper, also die Körper der reellen Zahlen, der komplexen Zahlen u.v.m.; mit geometrischen Figuren hat das nichts zu tun.



  • Wie wäre es mit moveCorpus()?

    Corpus ist die englische Übesetzung von Körper, damit deckt man alle geschlossenen geometrischen Körper mit einem Volumen ab.

    Eine Fläche ist zweidimensional, für die würde ich etwas anderes nehmen.
    Vielleicht moveSurface()



  • Sorry für die späte Rückmeldung. Ist es beim Englischen nicht wichtig, aus welchen Bereich der Begriff kommt? Und Corpus kommt doch eher aus dem anatomischen oder künstlerischen Bereich. Während es hier um mathematische bzw geometrische Flächen und Körper geht.

    Ich hatte eigentlich angenommen, das Bashar schon ganz korrekt auf den Umstand hingewiesen hatte?



  • @lemon03
    Nene, du verstehst das nicht. computertrolls weiss Dinge grundsätzlich besser.



  • Alles klar, danke 😉


Log in to reply