cabal install hsdev failt



  • Configuring old-time-1.1.0.3...
    cabal.exe: The package has a './configure' script. If you are on Windows, This
    requires a Unix compatibility toolchain such as MinGW+MSYS or Cygwin. If you
    are not on Windows, ensure that an 'sh' command is discoverable in your path.
    [...]
    cabal: Error: some packages failed to install:
    cpphs-1.20.8-BDBXpWYKWGd7dUd0Yrio1F depends on cpphs-1.20.8 which failed to
    install.
    haskell-names-0.9.1-GoUG61eWO13EA3An62OFCc depends on haskell-names-0.9.1
    which failed to install.
    haskell-src-exts-1.20.1-9aKDQVPNEDuF6QIagM83dR depends on
    haskell-src-exts-1.20.1 which failed to install.
    haskell-src-exts-util-0.2.2-JLmoqopKWGs1SAymuWjy4f depends on
    haskell-src-exts-util-0.2.2 which failed to install.
    hlint-2.0.15-Czsh7ZEFaJ9HVidHeObfll depends on hlint-2.0.15 which failed to
    install.
    hsdev-0.3.1.2-Fq3RHMCGn6G7Dp6irlBw5a depends on hsdev-0.3.1.2 which failed to
    install.
    old-time-1.1.0.3-LmKk8FUXtYwDVw5bR99HBe failed during the configure step. The
    exception was:
    ExitFailure 1
    

    Das ist der Fehler. Was kann man da machen? MinGW und MSYS ist installiert.

    Was auch nicht geht:

    cabal install ghc-mod
    Resolving dependencies...
    cabal.exe: Could not resolve dependencies:
    trying: ghc-mod-5.8.0.0 (user goal)
    next goal: base (dependency of ghc-mod-5.8.0.0)
    rejecting: base-4.10.1.0/installed-4.1... (conflict: ghc-mod => base<4.10 &&
    >=4.6.0.1)
    rejecting: base-4.10.1.0, base-4.10.0.0, base-4.9.1.0, base-4.9.0.0,
    base-4.8.2.0, base-4.8.1.0, base-4.8.0.0, base-4.7.0.2, base-4.7.0.1,
    base-4.7.0.0, base-4.6.0.1, base-4.6.0.0, base-4.5.1.0, base-4.5.0.0,
    base-4.4.1.0, base-4.4.0.0, base-4.3.1.0, base-4.3.0.0, base-4.2.0.2,
    base-4.2.0.1, base-4.2.0.0, base-4.1.0.0, base-4.0.0.0, base-3.0.3.2,
    base-3.0.3.1 (constraint from non-upgradeable package requires installed
    instance)
    After searching the rest of the dependency tree exhaustively, these were the
    goals I've had most trouble fulfilling: base, ghc-mod, syb
    


  • Haskell Platform 8.2.2 64 auf Windows 10 64.





  • sh.exe ist in PATH.

    Using ld found on system at: C:\Program Files\Haskell
    Platform\8.2.2\mingw\bin\ld.exe
    No lhc found
    No lhc-pkg found
    No pkg-config found
    Using runghc version 8.2.2 found on system at: C:\Program Files\Haskell
    Platform\8.2.2\bin\runghc.exe
    Using strip version 2.27 found on system at: C:\Program Files\Haskell
    Platform\8.2.2\mingw\bin\strip.exe
    No tar found
    No uhc found
    Searching for sh in path.
    Cannot find sh on the path
    cabal.exe: The package has a './configure' script. If you are on Windows, This
    requires a Unix compatibility toolchain such as MinGW+MSYS or Cygwin. If you
    are not on Windows, ensure that an 'sh' command is discoverable in your path.
    cabal: Leaving directory 'C:\Users\Keller\AppData\Local\Temp\cabal-tmp-1740\old-time-1.1.0.3'
    World file is already up to date.
    CallStack (from HasCallStack):
      die', called at .\Distribution\Client\Install.hs:996:15 in main:Distribution.Client.Install
    cabal.exe: Error: some packages failed to install:
    old-time-1.1.0.3-LmKk8FUXtYwDVw5bR99HBe failed during the configure step. The
    exception was:
    ExitFailure 1