Pointer Objekt aus einfachen add Funktion wird nicht ausgegeben



  • Hallo 👋🏻 Leute!

    Versuche gerade eine Flughafenverwaltung zu schreiben.
    Habe eine Airport Klasse mit Namen, flughafencode, latitude, longitude ( Flughafen Frankfurt (FRA), Sowie Maßeinheiten für Landebahn).

    In einer weiteren Klasse Flight sind Infos über Flug:

    Flight(string flightNumber, const string& startflughafen, const string& zielflughafen);
    

    Eine addZwischenstopp Funktion mit Pionter auf ein Airport Objekt
    Sowie einen Vector<Airport*> overstop; welches die Zwischenflüge speichert
    Dazu ist noch ein Airport* m_zwischenstopp als Verweis auf Airport Objekt definiert

    Problem macht mir die add Funktion:

    void Flight:: addZwischenstopp(Airport* m_zwischenstopp);
    {
       overstop.push_back(m_zwischenstopp);
    }
    
    // eine Printfunktion zur Ausgabe der Flüge
    void print()
    {
       cout<< flightNumber << startflughafen << zielflughafen << endl;
        for(unsigned int i = 0; i < overstop.size(); i++)
        {
          overstop[i]->print();
          cout <<endl;
        }
    
    }
    

    Meine Main():

    int main()
    {
      Airport* b = new Airport( „ New York „ , „NY“, 65.666, 54.777);
    
      Flight f(„LH-345“ , „ Frankfurt „ , „ Los Angeles“);
      f.print();
      f.addZwischenstopp(b); // keine Ausgabe 
    
      return 0;
      }
    


  • f.print();
    f.addZwischenstopp(b); // keine Ausgabe
    

    Du weißt schon, daß die Zeilen sequentiell ausgeführt werden?



  • Th69 schrieb:

    f.print();
    f.addZwischenstopp(b); // keine Ausgabe
    

    Du weißt schon, daß die Zeilen sequentiell ausgeführt werden?

    ja das ist mir bewusst , aber wenn ich die print() Funktion nach add() mache, bekomme ich nur das Airport angezeigt , ohne Flight.
    ich möchte aber, dass er auch von nach und über Flüge anzeigt 🙄



  • Dann debugge doch einfach deinen Code...



  • Th69 schrieb:

    Dann debugge doch einfach deinen Code...

    😃 😃 😃 😃 😃 Danke. Es hat immer noch paar Macken aber es funktioniert!!


Log in to reply