irc.ELF client is not working at QEMU with RTL8139? Bug reports inside



  • I am running the PrettyOS floppy "pretty.img" at QEMU under Ubuntu Linux with the following command:

    qemu-system-i386 -L . -m 256 -fda ./pretty.img -boot a -localtime -vga vmware
    -net nic,model=rtl8139 -net user -soundhw ac97 -usb -usbdevice tablet

    During the launch of PrettyOS I am already getting some error messages:

    Setup HID...
    UHCI: Timeout! Stalled HC still active HC still active
    HC still active
    Transfer failed.
    HID-Descriptor could not be read!
    port 2: 0080h Fullspeed

    > Press key to close this console. <<<

    Maybe this is normal and does not matter. Then I see this:

    ...
    Realtek RTL8139 network adapter:
    RTL8139C+

    USB UHCI 0: Host Controller Halted
    MAC: 52-54-00-12-34-56 IP: 192.168.1.22
    nambar: 0000C000 nabmbar: 0000C500 sample rate: 44100 Hz

    => Floppy Disk (1.44 MB): first drive found.
    => Only single partition on disk (type: FAT12)

    === Pretty OS booted ===

    > PrettyOS got a DHCP ACK. <<<

    USB UHCI 0: USB Error

    After that, I try to launch irc.ELF . Sometimes I get this problem:

    Stack backtrace:
    ebp: E0047B04 eip: 00126BE3
    ebp: E0047B44 eip: 001274BE
    ebp: E0047B64 eip: 0011ABC4
    ebp: E0047B84 eip: 00119CE4
    ebp: E0047BC4 eip: 00126D31
    ebp: E0047C34 eip: 00115084
    ebp: E0047C84 eip: 00115F55
    ebp: E0047CC4 eip: 001065B1
    ebp: E0047D28 eip: 001330D0
    ebp: E0047D48 eip: 00119CE4
    ebp: E0047E08 eip: 0010585C
    ebp: E0047E28 eip: 00105907
    ebp: E0047E68 eip: 001122D7
    ebp: E0047EA8 eip: 001136C2
    ebp: E0047ED0 eip: 00101DF2
    ebp: E0047F10 eip: 001066D7
    ebp: 014FFFE8 eip: 001330D0

    ASSERTION FAILED (current->data == data) in file 'kernel/util/ring.c', line 125
    OPERATING SYSTEM HALTED!

    The most far stage I have been able to advance to, was this:

    https://i.imgur.com/L6Ua4Xd.png

    It has successfully connected and I am able to see some messages printed by this server,
    but I could not write any of my new messages and could not send my new messages!

    This problem - is it because this irc.ELF client is at alpha development stage?
    Why I am unable to write my messages? Or maybe there is some incompatibility?
    Please help me to understand, is IRC client supposed to be stable or still not?

    Best regards,
    infarmer8



  • Hi,

    thanks for your feedback!

    Regarding the IRC client, it is not obvious how to use it; I just tried it out and it works as intended. To join a channel, press CTRL+j. To issue a command, press CTRL+c. To send a message to #PrettyOS (on euirc.net), press CTRL+p.

    The crash from kernel/util/ring.c would require more analysis; in general it is a strong hint that something in the kernel went wrong. Unfortunately, I do not have time to do this analysis (and I would need to reproduce the issue to fix it, anyway). If you have done any analysis or even found out the reason, we would appreciate if you can tell us!