APP veröffentlichen im Android Store



  • Hallo zusammen

    Ich erstelle mit dem C++ Builder Apps für Android. Seit diesem Monat kann ich meine Apps im Google Play Store nicht mehr veröffentlichen, weil der Upload mit der folgenden Fehlermeldung endet:

    Deine App ist derzeit auf API-Ebene 14 ausgerichtet, sollte jedoch eine API-Mindestebene von 26 haben. Hierdurch soll sichergestellt werden, dass deine App den neuesten APIs entspricht, Nutzern eine optimale Leistung bietet und sicher ist. Wir empfehlen dir, deine App auf die API-Mindestebene 26 auszurichten.
    

    Als Handy habe ich ein Samsung Galxy Note 3 mit Android 5.1.1. Bedeutet das, dass ich mir ein neues Handy besorgen muss oder wie kann ich die API-Ebene erhöhen?
    Im Android SDK-Manager habe ich API 28 installiert. Beim Kompilieren wird aber immer vorgängig API 22 Installiert. Hat jemand auch diese Problem und weiss was man da machen kann.

    Gruss Renato



  • => Embarcardero hinkt bei der Android-API hinterher

    Da wirst du wohl demnächst eine neuere IDE-Version benötigen, aber solange (oder du bleibst dann dabei) kannst du die Anpassungen selber vornehmen (wie in dem Blog-Beitrag beschrieben) - wichtig ist dabei android:targetSdkVersion="26".

    Tipp: Bei so etwas mal im Internet mit passenden Suchwörtern recherchieren: "C++ Builder Android app api version".