HowTo: Raspi Samba File-Server für Windows sichtbar machen



  • In make-samba-share-visible-in-windows-network wird eine Lösung gesucht, dass Netzlaufwerke, die mit Samba eingerichtet wurden, im Windows im Explorer unter Netzwerk angezeigt werden.

    In diesem Beitrag handelt es sich zusätzlich beim Server um einen Raspi 4 mit Arch Linux ARM als OS.

    Auszug aus /etc/samba/smb.conf (Konfiguration für den File-Server; z.B. das angegebene Verzeichnis bzw. das an dieses Verzeichnis gemountete Laufwerk)

    [ntfs_share]
    comment = Rasp NTFS Public Share
    path = /home/share
    browsable = yes
    writable = yes
    guest ok = yes
    

    Erwähnt wird wsdd. Also mit git klonen und mit makepkg -si ziehen, erstellen, mögliche Abhängigkeiten installieren und wsdd2 installieren. Falls Schlüssel fehlen, gpg --recv-keys und gpg --lsign-key mit dem angezeigten fehlenden Schlüssel jeweils ausführen, dann sollte es gehen. Schlüssel standen auch schon in der PKGBUILD Datei.

    Aber was passiert dann auf einem Raspi. Eine Fehlermeldung wird ausgegeben. Um den Fehler zu beheben, die Datei PKGBUILD öffnen und die Zeile mit arch=(x86_64) suchen und x86_64 mit armv7h ersetzen und erneut makepkg -si ausführen. Dies funktionierte auch schon mit anderen Packages. Der Tipp, dass dies funktionieren kann, stand bei den Kommentaren einer AUR-Package-Webseite, aber ich weiss jetzt gerade nicht mehr bei welchem Package.

    Edit: Ich bin mir nicht mehr sicher ob noch systemctl start wsdd2.service und systemctl enable wsdd2.service ausgeführt werden muss. Der Status lässt sich mit systemctl status wsdd2.service abfragen. Der Server muss mit Samba fertig eingerichtet sein, wozu es Tutorials gibt. Mit "Netzlaufwerk verbinden..." lässt sich der Server auch ohne wsdd2 einbinden, wenn er mit Samba korrekt konfiguriert ist. Er wird einfach nicht unter Netzwerk angezeigt.

    Edit: Funktionierte nur so lange es mit Kabel mit dem Router verbunden war. Als ich auf wlan wechselte, funktionierte es nicht mehr. Ich finde Netzwerke zu verstehen anspruchsvoll. Im Moment geht es zwar wieder, mit WLAN.


Log in to reply