can't find compiler executable [...]



  • Hallo,

    ich habe mir unter auf einem frischen Linux Mint 19.3 Xfce Codeblocks 20.03 installiert und habe festgestellt, dass beim öffnen eines Testprojekts
    angezeigt wird :

    can't find compiler executable in your search path (GNU GCC compiler)
    

    Ich habe ein paar fixes für windows gefunden wo ich in den global compiler settings unter den toolchain tab den pfad der .exe angeben soll.
    Bei mir steht da das drin

    /opt/intel/cc/9.0
    

    Weiß jemand wie ich das Problem fixen kann?

    Danke


  • Mod

    /opt/intel/cc/9.0 klingt ja nicht gerade nach einem typischen Pfad für einen GNU GCC. Hast du den Intelcompiler installiert und möchtest ihn benutzen? Sieht so aus, als hättest du nur eine Verzeichnisangabe gemacht, wo eine komplette Angabe der Executable (Ohne Gewähr: icc bei Intel) erwartet wurde. Außerdem wirst du Code::Blocks noch sagen müssen, dass das ein Intelcompiler ist, damit es weiß, wie die Kommandozeilenparameter aussehen müssen.

    Es wird auch viele Anleitungen im Netz geben, wie man den Intelcompiler für Code::Blocks einrichtet. Wobei die meisten davon darauf hinaus laufen, dass man ihn einfach im Klickibuntimenü auswählt und Code::blocks macht alles automatisch. Daher die Frage, ob das überhaupt dein Vorhaben ist, und was du überhaupt getan hast, um in diesen Zustand zu kommen.



  • @SeppJ

    eigentlich sind das die default settings und ich habe noch garnichts gemacht außer zu installieren.
    Ich würdegern, wie bisher den g++ compiler nutzen, der aber nicht zu finden ist.
    bzw. es springt immer wieder zu dem blöden Intel compiler.

    edit : ich kann jetzt doch wechseln nach neustart von CB aber jetzt wirft mir der Compiler

    ||=== Build: Release in hello word (compiler: GNU GCC Compiler) ===|
    ||error: ld returned 1 exit status|
    ||=== Build failed: 1 error(s), 0 warning(s) (0 minute(s), 0 second(s)) ===|
    
    

  • Mod

    Gibt es eine Möglichkeit, an die ld Fehlermeldungen zu kommen? Hast du auch alles richtig für C++ (statt C) eingestellt?



  • @SeppJ

    Wo finde ich üblicherwise die ld Fehlermeldungen?

    Falls du das meinst :

    g++  -o "bin/Release/hello word" obj/Release/main.o  -s  
    /usr/bin/ld: obj/Release/main.o: _ZSt4cout: invalid version 3 (max 0)
    obj/Release/main.o: error adding symbols: Ungültiger Wert
    collect2: error: ld returned 1 exit status
    Process terminated with status 1 (0 minute(s), 0 second(s))
    1 error(s), 0 warning(s) (0 minute(s), 0 second(s))
     
    

    Ich habe bei den compiler settings : GNU GCC Compiler als selected compiler

    und unter compiler flags " C++11 GNU C++ lang. standard"



  • @Lou-Cyphr3 sagte in can't find compiler executable [...]:

    hello word

    Das ist jetzt nicht dein Ernst...



  • @manni66

    ähm doch. das ist der projektname des testprojekts und ja ich habe mich vertippt.

    Aber ich tippe darauf, dass ein eingefügtes "l" , die Sache leider nicht bereinigen wird.


  • Mod

    Kannst du bitte noch mehr Output zeigen, den der vor der Zeile 1 in deinem Beitrag kommt?



  • Mal ganz davon abgesehen: verwende keine Leerzeichen in Pfaden in Kombination mit g++, gdb und c::b.

    sudo apt-get install build-essential
    g++ --version



  • @SeppJ

    das ist der gesamte output

    -------------- Build: Release in hello word (compiler: GNU GCC Compiler)---------------
    

    Das kommt lediglich davor.

    @5cript

     g++ --version
    g++ (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0
    Copyright (C) 2017 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    
    

    gleiches Problem.



  • ist da noch das produkt vom intel compiler vorhanden?
    Versuchst du das object file vom intel compiler mit ld zu linken?

    Mach den build mal komplett sauber.
    Das ist das einzige was ich mir gerade vorstellen kann was das Problem ist.

    Weil wenn das alles im output log ist, dann ist das nur der linker step, ohne das kompilieren.


  • Mod

    @Lou-Cyphr3 sagte in can't find compiler executable [...]:

    @SeppJ

    das ist der gesamte output

    -------------- Build: Release in hello word (compiler: GNU GCC Compiler)---------------
    

    Das kommt lediglich davor.

    Häh? Da wird ja nirgendwo etwas übersetzt. Wo kommt main.o her? Mach mal alles sauber und neu von vorne.



  • @5cript okay was meinst du komplett sauber machen? Einfach refreshen?



  • Alle in deinem Projekt vom Compiler/Linker erzeugten Dateien löschen. Also insbesondere alle .o, .so und .a-Dateien deines Projektes. Und dann die Ausgabe beim neu Erzeugen vollständig zeigen.





  • @SeppJ @5cript

    Also ich habe beides getan : .o files gelöscht, refresht und sogar ein neues testprojekt angelegt aber alles ohne Erfolg.

    Wie kann ich hier ein .png anhängen, dann zeig ich euch nochmal die global compiler settings....



  • Die musst du selber hosten, die Bilder.

    Während du ein weg findest die bilder hochzuladen:
    hast du mal probiert manuell alles vom terminal zu machen?
    Ob das überhaupt geht?

    g++ -c main.cpp -o main.o
    g++ -o myProg main.o -s



  • also übers terminal gehts.
    ich schau mal wegen den screenshots





  • ich kriege 403 forbidden bei den links


Log in to reply