Probleme mit PHP und der gd.lib



  • Hallo, ich habe Probleme mit PHP und der gd.lib
    Ich benutze Apache 1.3.26 und php 4.2.2, das ';' vor 'extension=php_gd2.dll' habe ich
    in der php.ini entfernt.

    Wenn ich den Quelltext :

    <body> 
    <?PHP 
    
    header ("Content-type: image/png"); 
    $image = imagecreate(300,150); 
    $farbe_body = ImageColorAllocate ($image,123,123,123); 
    ImagePNG($image); 
    
    ?> 
    </body>
    

    ausführe, bekomme ich folgende Ausgabe:

    Warning: Cannot add header information - headers already sent by (output started at c:\apache\apache\htdocs\image\test.php:3) in c:\apache\apache\htdocs\image\test.php on line 4
    ‰PNG  IHDR<a href=",–<a href=">^•'‘>PLTE{{{ô²âIDATxœíÁ<a href="  ÷Om7 àÉÚ<a href="óBÖIEND®B`‚

    Kann mir jemand sagen woran das liegt, bzw. was zu tun ist, damit's funktioniert?

    [ Dieser Beitrag wurde am 04.09.2002 um 23:36 Uhr von D_Saster editiert. ]



  • die funktion header muss VOR dem ersten html kommen..

    übrigens ist html auch schon das öffnen..

    <html> <body> .. etc..

    knalls ganz an den anfang ohne leerzeichen



  • besser noch.. lass das ganze html hier weg.. nur php und .. ohne leerzeichen am anfang .)



  • Klappt leider immer noch nicht. Bekomme nur dieses Symbol anstelle von Bildern, wenn dieses nicht vorhanden ist.



  • Oben links muss folgendes stehen (und wirklich gar nichts mehr vor dem <?php):

    <?php
    header('Content-type: image/png');
    $image = CreateImage(300, 500);
    
    $Color = ImageColorAllocate($image, 123,123,123);
    ImageFill($image, 0,0, $Color);
    
    ImagePng($image);
    ?>
    

Log in to reply