FTP-Server hinter Router



  • Hi Leute,
    Hat jemand von euch eine Idee, wie ich vom Internet auf einen FTP-Server hinter nem Router zugreifen kann?
    Der FTP-Serverläuft hier auf meinem Rechner. Wenn ich aus dem lokalen Netzwerk auf ihn zugreife geht alles ohne Probleme. Wenn ich aber von ausserhalb versuche auf den FTP-Server mit der IP meines Routers zu connecten, geht das nicht. Er sagt: "Serververbindung konnte nicht hergestellt werden". Port 21 wird von meinem Router auf den Rechner weitergeleitet, auf dem der FTP-Server läuft.
    Hat irgendjemand eine Idee, woran das liegen kann, bzw, wie ich das zum Laufen bekomm?



  • Vielleicht auch noch Port 20 weiterleiten.
    Für passive ftp noch einen evtl. vom FTP-Server vergebenen Port-Range weiterleiten...



  • Eigentlich müsste Port 21 reichen - Vielleicht musst du den Router erst restarten oder so (wäre aber ziemlich unüblich ;D)
    Gib mal ne IP zum testen 😉



  • Hm, der FTP-Server läuft nur auf Port 21 ...
    Passives FTP ist deaktiviert ...
    Router muss man net neustarten, andere Portforwardings wurden sofort verwendet.
    Ich muss beim Einrichten des FTP-Servers ne Domäne einrichten ... Der kann ich nen Namen geben, den Port, auf dem sie läuft und die "Domänen IP Adresse". Da steht bei mir momentan "Verwende alle verfügbaren IP Adressen" drin ...
    Hat das vielleicht etwas damit zu tun?



  • Normalerweise reicht es, wenn man das Port 21 zur entsprechenden Subnetz-IP weiterroutet. Man muß halt bloß die IP des Routers als FTP-IP benutzen 🙂



  • aber genau das tu ich ja 😞
    Und es tut trotzdem net 😞



  • ok, es tut doch ... Ich kann nur nicht per DynDNS auf mcih selbst zugreifen ... ka, wieso ...

    Aber es gibt ein neues Problem:
    Wenn ich eine Verknüpfung auf ein Verzeichnis erstelle, diese Verknüpfung in das Startverzeichnis des Users lege und dem User Zugriff auf das Verzeichnis erlaube, auf das die Verknüpfung zeigt, dann bekommt er statt der verknüpfung direkt nen ordner angezeigt. Tut auch, solange der Ordner auf dem lokalen Rechner liegt. Wenn die Verknüpfung aber auf einen Ordner zeigt, der im Netzwerk liegt, dann funktioniert das ganze nicht mehr, auch, wenn ich dem Remoteverzeichnis per "Netzlaufwerk verbinden" einen Laufwerksbuchstaben gegeben hab. Habt ihr für dieses Problem vielleicht auch noch eine Lösung? 🙂



  • Welchen FTP-Server verwendest Du denn?
    Bei GuildFTP ging das über das Netzlaufwerk. Bei WarFTP habe ich es noch nicht direkt probiert - sieht aber so aus, als ob es dort auch geht...kanns ja evtl. mal testen, wenn Du diesen FTP-Server verwendest.



  • Ich verwende FileZilla ...


Log in to reply