Java Versionen



  • Hi,

    ich muss ein Applet schreiben, dass unter einer 1.1.8er VM laufen muss. Ferner muss es auf jeder MS VM laufen.
    Ich wollte jetzt mit dem SDK 1.3 entwickeln, und einfach keine Methode und Klasse > 1.1.8 benutzen. Wird dadurch Bytecode erstellt, der die oben formulierten Anforderungen erfüllt ?
    Ich habe einmal versucht, mit dem SDK 1.1.8_010/_16 zu arbeiten. Da es jedoch selbst beim kompilieren von "Hello World" Probleme gab, hab ich es wieder deinstalliert.
    Funktioniert also der Weg mit dem 1.3er SDK ?

    Danke



  • Hallo

    Ich glaube da muss du dann gewisse Compiler Optionen eingeben.
    Du kannst dem Compiler sagen für welche VM es compiliert werden soll.

    Ausserdem müsste 1.1.8 doch funktionieren. Wenn du 1.3.1 verwendest dann bis du nur auf die AWT Komponenten beschränkt.

    BYE


  • Mod

    So müßte das gehen:

    javac -target 1.1 MyClass.java

    Ich hoffe, dir ist klar, dass die MS-VM kurz vor dem Aussterben steht. Sie wird nicht mehr unterstützt und in Zukunft nicht mehr ausgeliefert.


Log in to reply