Visual C++ .NET 2002



  • Hallo zusammen,

    ich muss euch nochmal stören. Ich habe diese
    Frage zwar schon mal gestellt, jedoch keine
    verwendbare Antwort erhalten.

    Mein Visual C++ .NET 2002 listet mir beim Schreiben
    von Code weder Parameterinformationen bei Funktionen
    noch Elemente bei Strukturen und Klassen auf.
    Ich bin fast am verzweifeln, da die Version
    doch schon einiges gekostet hat und ich so
    kaum richtig arbeiten kann.

    Ich hoffe ihr könnt mir helfen.
    PS: Ich habe dieses Problem auf meinem
    Desktop PC und auf meinem Notebook.

    Danke schon mal im Voraus.

    Bye Peter.



  • Hallo Peter,

    Mein Visual C++ .NET 2002 listet mir beim Schreiben
    von Code weder Parameterinformationen bei Funktionen
    noch Elemente bei Strukturen und Klassen auf.
    Ich bin fast am verzweifeln, da die Version
    doch schon einiges gekostet hat und ich so
    kaum richtig arbeiten kann.

    ich verwende die gleiche Version (Standard) und es funktioniert bei mir prächtig. Also der Visual C++ .NET 2002 hat definitiv dieses nützliche Feature.
    Funktionieren denn bei Dir die Intellisense Features? (Menü Ansicht) ?
    Ausserdem schau mal bei den Optionen (Meü Extras->Optionen) unter C/C++, ob da da bei Anweisungsabschluss das Häkchen vor "Member automatisch auflisten" und "Parameterinformationen" gesetzt ist.

    Gruß
    Olli



  • Und bei

    Hoffe es hilft weiter.

    Gruß
    Michael



  • Visual C++ .NET 2002 listet meines Wissens nach diese IntelliSense-Infos nur, wenn die Datei auch in das aktuelle Projekt eingebunden ist!

    Aber ich benutze eh lieber VisualAssist .NET für die ToolTip-Info...



  • Hallo zusammen,

    "Member automatisch auflisten" und "Parameterinformationen"
    sind bei mir eingeschaltet. Alle Quelltextdateien, die
    ich verwende sind auch in das Projekt eingebunden.
    Ich werde mal nach den Intellisense Features schauen.

    @Hepi, ich werde mir auch mal
    "VisualAssist .NET" anschuen.

    Ich finde das auch ziemlich merkwürdig, da es
    in der 6er VC++ Version bei mir auf Arbeit auch
    immer funktioniert hatte.

    Bye Peter.



  • In der FAQ findest Du noch einen Beitrag bezüglich InteliSense und VC. vllt. hilft Dir das weiter.



  • Hallo nochmal,

    ich habe jetzt herausgefunden wann es bei mir nicht klappt.
    Ich habe per Assistent eine Consolenanwendung erstellt.
    Wenn ich die Option "leeres Projekt" anhake, funktioniert
    die automatische Vervollständigung nicht.

    Keine Ahnung warum. Ich habe die Optionen beider
    Projekte verglichen und keinen Unterschied gefunden.

    Bye Peter.



  • Hallo Peter,

    Ich habe per Assistent eine Consolenanwendung erstellt.
    Wenn ich die Option "leeres Projekt" anhake, funktioniert
    die automatische Vervollständigung nicht.

    Das ist aber merkwürdig. Ich habe gerade aktuell selber genauso eine Applikation erstellt und die AutoVervollständigung klappt einwandfrei. Vielleicht liegt es am System (DLL's etc.)? 😕
    Ich arbeite unet Win XP Prof. SP1.

    Gruß
    Olli



  • @OlliNRW,

    ich habe Windows 2000 Professional mit SP3.
    Das Problem ist ja, das es auf meinem Notebook
    genau das gleich Problem gibt.

    PS: Notebook - ebenfalls Windows 2000 Pro mit SP3

    Trotzdem danke für die schnelle Hilfe.

    Bye Peter.



  • Hallo Peter,

    also ich vermute immer mehr den Fehler im Zusammenspiel Visual C++ .net <-> Win 2000. Falls jemand diese Kombination betreibt sollte er mal posten ob es bei Ihm klappt/ nicht klappt.
    Ansonsten fällt mir nur noch ein bei MS die Knowledge Base zu durchforsten.

    Gruß
    Olli



  • W2K SP3 -> Keine Probleme



  • Hallo zusammen,

    ICH HABE ES HINBEKOMMEN.

    Ich habe Quelltextdateien immer über Datei->Neu erstellt
    und dann per "Bereits existierende Datei dem Projekt hinzufügen"
    oder so ähnlich in mein Projekt eingebunden.
    DAS FUNKTIONIERT NICHT.
    Wenn ich aber eine neue Datei dem Projekt hinzufüge,
    klappt alles.

    Danke für alle die mir geholfen haben.

    Bye Peter.


Log in to reply