Java 1.1 kompatible Applets erzeugen



  • Hi!

    Mit dem Jdk1.4 soll es ja möglich sein Java1.1 kompatible Bytecodes für Applets zu kompilern. Ich weiß, dass es die Compileroption „target“ gibt, kann aber nicht herausfinden, wie man die jetzt richtig hernimmt bzw, ob diese überhaupt dafür gedacht ist. Nach „+javac +target“ zu suchen hat sich als absoluter Reinfall erwiesen....

    Bitte um einen kurzen Tip.

    Danke und schönen Gruß!

    Bronks



  • Hoi.

    Ich habe genau das selbe "Problem" und muss auch Applets erstellen, die auch noch auf ner 1.1.8er VM laufen müssen.

    Mit einem 1.4er SDK hatte ich dabei allerdings wenig Erfolg, weshalb ich mir ein 1.1.8er SDK gesaugt hab und damit alle Klassen kompilier.
    Ältere SDKs und JRE findest du hier: http://java.sun.com/products/archive/index.html

    flo



  • hi

    ich habe es mit normalen javaprogrammen (keine applets) mal so gemacht:

    -target <version>
    erlaubt die Angabe der Java-Version, mit der die erzeugten Klassendateien kompatibel sind. Gültige Werte für <version> sind 1.1, 1.2, 1.3 und 1.4. Dabei gilt jeweils, dass der erzeugte Bytecode jeweils auf allen VMs der jeweiligen Version und neueren Versionen läuft, nicht aber auf älteren. Bei Angabe von 1.3 werden also Klassendateien erzeugt, die sowohl auf Interpretern der Version 1.3 als auch auf Interpretern der Version 1.4 lauffähig sind, nicht aber auf 1.1 oder 1.2. Die Voreinstellung ist 1.4.

    http://www.dpunkt.de/java/Anhang/Tools/6.html



  • Hi!

    Vielen Dank euch beiden.

    Es funktioniert einwandfrei. Hab gestern, in übermüdentem Zustand, die Dummheit gemacht "target" als Interpreteroption anstatt für den Compiler einzutragen.

    Weiß zufällig jemand wie ich nur anhand der .class-Datei herausfinden kann für welche Version diese kompilert wurde?

    Schönen Gruß!

    Bronks


  • Mod

    Ich finde es unglaublich, dass es immer noch Leute gibt, die das Ziel haben, für Java 1.1 zu entwickeln. Es sollte sich doch inzwischen rumgesprochen haben, dass die MS-VM, wegen der das gemacht wurde, gerade dabei ist, auszusterben.





  • versuche es mal mit

    java -showversion


Log in to reply