2 Netzwerkkarten



  • Hallo Leute!

    Ich wollte einen Mandrake-PC als Router verwenden...

    Also 1. Netzwerkkarte rein und ADSL konfiguriert - funktioniert perfekt.
    Dann 2. Karte rein und nix geht mehr. Ich kann umstellen was ich will, aber er will zB nicht mehr ins Internet - mit nur 1er Karte funktioniert es aber.

    Das ADSL läuft über pptp.

    eth0 soll die Verbindung zum Internet haben, und eth1 soll die einkommenden Netzwerkverbindungen aktzeptieren. Mein Vater vermutet, dass sich die beiden Karten (IP Adressen 10.0.0.199 und 10.0.0.188) nicht verstehen 😞

    Was kann man da machen? Habt ihr vielleicht gute Links zu diesem Thema?



  • Hi!

    Ich weiß nicht genau worans liegt, aber du kannst mal folgendes versuchen:

    Log dich als root ein, und gib in der Konsole ein:

    $ ifconfig

    Damit sollte der deine Ip Konfiguration anzeigen (wie ipconfig in Windows).
    Hier kannst du erstmal gucken ob die Konfiguration OK ist.

    Dann kannst du mal mit dmesg gucken, ob der Kernel vielleicht nur
    eine Karte gefunden hat.

    Probier das mal, und poste mal die Ergebnisse 🙂

    Ps.:
    Wenn du dem Mandrakeconfigtool nicht vertraust, kannst du das Script unten
    verwenden. Das ist von der Gentoo Live CD, sollte aber auch für andere Linuxe
    (oder Linusse? Was ist der Plural) klappen. Aufruf ist net-config eth0
    z.b.

    net-config

    #!/bin/bash
    [ "$1" = "" ] && echo "net-setup: please specify a network interface" && exit 1
    [ ! -d /tmp/setup.opts ] && mkdir /tmp/setup.opts
    cd /tmp/setup.opts
    dialog --title "Network Setup" --menu "Time to set up the $1 interface! You can use DHCP to automatically configure a network interface or you can specify an IP and related settings manually. Choose one option:" 20 60 7 0 "Use DHCP to auto-detect my network settings" 1 "Specify an IP address manually" 2> ${1}.1
    mynetsel=`cat ${1}.1`
    case $mynetsel in
    0)
    	/sbin/dhcpcd -t 10 
    	;;
    1)
    	dialog --title "IP address" --inputbox "Please enter an IP address for $1:" 20 50 "192.168.1.1" 2> ${1}.IP
    	dialog --title "Broadcast address" --inputbox "Please enter a Broadcast address for $1:" 20 50 "192.168.1.255" 2> ${1}.B
    	dialog --title "Network mask" --inputbox "Please enter a Network Mask for $1:" 20 50 "255.255.255.0" 2> ${1}.NM
    	dialog --title "Gateway" --inputbox "Please enter a Gateway for $1 (hit enter for none:)" 20 50 2> ${1}.GW
    	dialog --title "DNS server" --inputbox "Please enter a name server to use (hit enter for none:)" 20 50 2> ${1}.NS
    	/sbin/ifconfig $1 `cat ${1}.IP` broadcast `cat ${1}.B` netmask `cat ${1}.NM`
    	myroute=`cat ${1}.GW`
    	if [ "$myroute" != "" ]
    	then
    		/sbin/route add default gw $myroute dev $1 netmask 0.0.0.0 metric 1	
    	fi
    	cp /etc/resolv.conf /etc/resolv.conf.orig
    	myns="`cat ${1}.NS`"
    	if [ "$myns" = "" ]
    	then
    		: > /etc/resolv.conf
    	else
    		sed -e "s:##NS1##:${myns}:" /etc/resolv.conf.orig > /etc/resolv.conf
    	fi
    	;;
    esac
    echo "Type \"ifconfig\" to make sure the interface was configured correctly."
    


  • kannst du dich noch einwählen und es kommen keine verbindungen zu z.b. webservern zu stande? oder kannst du dich überhaupt nicht einwählen? hatte da nämlich mal ein ähnliches problem.



  • Shade: Kann es sein dass Du zwei Netzwerkkarten mit dem gleichen Chipsatz verwendest? 😉

    Headhunter: ifconfig kann man auch als normaler User verwenden, es liegt halt in /sbin...


Log in to reply