Listenproblem



  • Hhhhm, ich hab ein Problem:

    Ich habe eine XHTML1.1-Seite erstellt, in der eine <ul>-Liste vorkommt. Nach der Letzten Zeile im Quellcode zeigt der IE zwei der drei Listenelemente aus der Liste von oben nocheinmal. Was Kann ich dagegen tun, woher kommt das???
    đŸ˜”

    mfg
    Glamdring



  • Hast du deine Tags auch immer schön brav wieder geschlossen??



  • Und hast du die mal mit dem Validator vom W3C auf Syntax-Fehler ĂŒberprĂŒft?!



  • Die Tags sind richtig geschlossern, aber der Validator sagt folgendes:

    Line 61, column 3: document type does not allow element "ul" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

    Muss ich dann Tabellen mit Bildpunkten (Bildern von Punkten) arbeiten, wenn ich trotzdem XHTMl1.1 haben möchte???

    mfg
    Glamdring



  • Probier's mal mit nem DIV außernrum - und zeig evtl. mal den Codeausschnitt (oder alles - je nach LĂ€nge)



  • Das mitm div hat nichts gebracht, hier dea Code:

    <div class="main">
    <p class="around">
    <br/>
    <b id="yellowover">Kooperationspartner:</b><br/><br/><br/>
    <span class="text"> <!--Irgendein Text-->
    <ul>
    <li>
        die St&auml;rkung der Pers&ouml;nlichkeitsentwicklung und 
        der sozialen Kompetenzen des Vorschulkindes sowie
    </li>                                                         
    <li>
    	die F&ouml;rderung der Lernm&ouml;glichkeit. Entscheidend ist, dass das
        Kind lernen, will (Lernbereitschaft) und dass es lernen kann 
        (Lernf&auml;higkeit). Schon vor Schulbeginn m&uuml;ssen
    </li>
    <li>
       die Grundlagen zum Erlernen der Kulturtechniken 
       Lesen, Schreiben und Rechnen gef&ouml;rdert und 
       eventuell vorhandenen Lernschw&auml;chen erkannt und 
       gef&ouml;rdert werden.
    </li>  
    </ul> 
    <!--Irgendein Text-->
    <!--Nach dem obigen Text werden die zweite und dritte Listenzeile hier nocheinmal angezeigt-->
    </p>
    </div>
    

    mfg
    Glamdring



  • Offenbar darf man <ul> nicht in ein <p> schachteln 🙄

    Außerdem hast du ein "loses" <span> und statt <br/> sollte man bzgl. der KompatibilitĂ€t besser <br /> shreiben



  • das mitm span ist ein kopierfehler 🙄
    Aber ohne das <P> gehts!

    thx
    Glamdring


Log in to reply