Fehler beim Kompilieren, findet Standardheader nicht mehr



  • Also, ich ein projekt da arbeite ich schon länger dran.
    Jetzt hab ich es nach ner Zeit wieder soweit, das ich
    alles kompilieren kann, er bricht jedeoch mit der Fehlermeldung
    "fatal error C1034: iostream: Kein Suchpfad fuer Header-Dateien vorhanden"
    ab, die Include Pfade sind aber ALLE 100% gesetzt, und der Fehler
    tritt nur in diesem Projekt auf. Die Selben quellcodedateien
    kann ich unter einem anderen Projekt problemlos Kompilieren.
    Wie gesagt, ich habe die Includepfade schon alle überprüft,
    da ist garantiert kein fehler. Und er findet auch nur die Standardheader nicht.
    Ich benutze MS VC 6.0 als Kompiler.
    Achja, das Problem betrifft nur die Release Einstellung, unter Debug klappt es
    einwandfrei...

    Kennt jemand einen Weg den Fehler zu beseitigen?

    Devil



  • So, ich weiss nicht, ob es eine lösung gibt, die einem die Arbeit erspart,
    aber wenn man das projekt "umtopft", ist der fehler wieder weg.
    Also, Ordner umbenennen, neues Projekt mit selben Namen aufmachen,
    dann die entsprechenden Dateien im neuen Projekt löschen(alle Quellcode dateien,
    und den res ordner), danach alle Quellcodedateien und die res vom alten
    Ordner in den neuen kopieren. Klassen in das Neue Projekt wieder einfügen, fertig.

    Devil



  • Hallo,

    ich weiß nicht, ob es dieses Problem bei dir war, aber:

    Unter Menü "Projekt"->"Einstellungen", Registerkarte "C/C++", Kategorie "Präprozessor"

    gibt es die Option "Standard-Include-Pfade ignorieren", und diese Einstellung ist projekt-spezifisch, da können die anderen Optionen und Include-Pfade noch so richtig gesetzt sein, das wird dann trotzdem zu diesem Fehler führen

    MfG



  • Danke für den Tipp.
    Aber es liegt nicht an der Einstellung.
    Und wie gesagt, es funktioniert jetzt wieder.

    Devil


Log in to reply