Falsche FAQ???



  • Hallo!
    Ich habe mir folgendes Posting in der FAQ angeschaut:
    http://www.c-plusplus.net/forum/viewtopic.php?t=39308,
    aber irgentwie geht das bei mir nicht:
    ➡ cpp1.obj - 5 error(s), 7 warning(s)
    Ich hab übrigens visual c++ 6.0 autoren edit.
    Kann das was damit zu tun haben 😕



  • Toll du hast 5 Fehler - welche das sind lässt du uns per Gedankenkontrolle erraten? 🤡

    MfG SideWinder



  • Genau 😃

    Aber für die, die keine übernatürlichen Fähigkeiten besitzen:

    : warning C4018: '<' : signed/unsigned mismatch
    : warning C4244: '=' : conversion from 'unsigned long' to 'short', possible loss of data
    : warning C4018: '<' : signed/unsigned mismatch
    : warning C4244: '=' : conversion from 'unsigned long' to 'short', possible    loss of data
    : warning C4244: '=' : conversion from 'unsigned long' to 'short', possible loss of data
    : warning C4244: '=' : conversion from 'unsigned long' to 'short', possible loss of data
    : warning C4018: '>' : signed/unsigned mismatch
    : error C2014: preprocessor command must start as first nonwhite space
    : error C2143: syntax error : missing ')' before '{'
    : error C2059: syntax error : ')'
    : error C2143: syntax error : missing ';' before '{'
    : error C2181: illegal else without matching if
    Error executing cl.exe.
    
    Browser.obj - 5 error(s), 7 warning(s)
    


  • Äh ok, erster Schritt; jetzt fehlt nur noch der Code dazu. 🙂



  • nman schrieb:

    Äh ok, erster Schritt; jetzt fehlt nur noch der Code dazu. 🙂

    Der steht doch in den FAQ 🙄



  • schau dir den ocde in der faq an... der produziert nicht diese fehlermeldung.

    da muss der fragesteller mal den gesamten code zeige 😉



  • Er sollte sich auf alle Fälle nochmal die Klammersetzung anschauen 🙂



  • Ich vermute jetzt einfach mal es liegt daran:

    FAQ schrieb:

    if ( csbi.dwSize.X > SizeX || csbi.dwSize.Y > SizeY )
    

    Vielleicht sollte man doch nicht immer so vertrauensvoll Copy & Paste machen ;).

    Habs in der FAQ geändert.



  • Jo! Daran lag's 👍



  • oki, lag ich doch falsch.



  • omg wie kommen die da rein? Hat der Konverter von Gerard n bissel versagt 🤡

    MfG SideWinder



  • @Side
    Möglich. Mit den HTML-entities ( &entity; ) hat er teilweise Probleme. Besonders wenn man eigentlich gar keins angeben will ;). Allerdings ist es schon länger her, dass ich so ein Problem hatte. Vielleicht hat er es mittlerweile gelöst.


Log in to reply