Problem bei der Installation von Allegro für Dev-Cpp



  • Hi,

    Ich versuche im Moment Allegro für dev-cpp zu installieren, bin dabei jedoch auf Probleme gestossen.
    Ich habe mich genau an diese Anleitung gehalten:
    http://www.allegro.cc/files/install-devcpp.html.
    Von den angegeben Programmen habe ich mir jeweils die neueste Version heruntergeladen und trotzdem (oder deswegen?) kam es zu Problemen als ich Allegro kompilieren wollte. Ständig kam die Meldung

    -mcpu´= is deprecated. Use ´-mtune=´ or ´-march=´instead

    . Trotzdem schien der Rest normal weiterzulaufen- auch mit make install hatte ich keine Probleme.
    Aber wenn ich nun versuche einen Quelltext mit Allegro-Befehlen mit dev-cpp zu kompilieren, kommt bei der Funktion textout_ex immer die Fehlermeldung:

    C:\Dev-Cpp\Unbenannt1.cpp `textout_ex' undeclared (first use this function)
    

    Auch bei anderen Quelltexten, bei denen ich mir sicher bin, dass sie keine Fehler enthalten, kommt es zu ähnlichen Fehlermeldungen.
    Kann mir jemand helfen?

    Vielen Dank im voraus 🙂



  • okey ich habe nun dev-cpp nochmal installiert und die neuste mingw-version in das dev-cpp verzeichniss entpackt. Diesmal klappte das kompilieren von Allegro
    reibungslos.
    Es treten aber immer noch bei allen Allegro beigelegten Testprogrammen Fehlermeldungen auf, wenn ich versuche sie mit dev-cpp zu kompilieren.
    So z.B. in dem Programm play (allegro/tests/play.c)
    kommt immer die Fehlermeldung:

    49 C:\Dev-Cpp\Unbenannt1.cpp invalid conversion from `void*' to `char*'
    

    Bitte helft mir 😕


Log in to reply