Visual studio 2005 professional edition + boost



  • Hi Leute
    Weis jemand von euch wie man die beiden miteinander verwenden kann?
    Also vs2005 prof. edition hab ich und bei boost weis ich ned genau was man da braucht!?
    Hoffe ihr könnt mir helfen



  • Dieses Packet saugen und installieren, im Visual Studio die Include-Pfade hinzufügen und schon bist du dabei 👍



  • Hm ja also ich hab jetzt den installer (boost_1_36_0_setup) heruntergeladen und istalliert! aber jetzt weis ich nicht genau wie ich die include verzeichnisse hinzufügen soll!? in dem verzeichniss:
    C:\Programme\boost\boost_1_36_0
    befinden sich jetzt folgende ordner:
    -bin
    -boost
    -doc
    -lib
    -libs
    -more
    -people
    -tools
    -wiki
    Wie man sieht ist da niergens ein include ordner oder so!
    und wo genau muss ich diese verzeichnisse in vs 2005 hinzufügen?



  • booster schrieb:

    Hm ja also ich hab jetzt den installer (boost_1_36_0_setup) heruntergeladen und istalliert! aber jetzt weis ich nicht genau wie ich die include verzeichnisse hinzufügen soll!?

    Steht alles in der Boosthilfe. Aber zur Verkürzung:

    Leg dir eine Umgebungsvariable (z.B. BOOST_ROOT) an, mit dem folgenden Wert:
    C:\Programme\boost\boost_1_36_0

    Danach einmal den Rechner neu Starten und dann als zusätzliches Includeverzeichnis: $(BOOST_DIR) hinzufügen.
    Als zusätzlichen Bibliothekspfad $(BOOST_DIR)\lib

    und die includes von Boost liegen im boost Unterverzeichnis, normalerweise gibt man dies (so alle Beispiele) explizit beim Include an: #include <boost/scoped_ptr.hpp>

    cu André



  • Naja ich hab zwar kein VS2005, sondern nur noch VS2008... anyway du musst zwei Directories als Standardpfade im VS angeben. Das machst du per Menu
    Tools/Options.../Projects and Solutions/VC++ Directories . Dort wählst du zuerst für Show directories for: den Eintrag Include files and trägst dort den Pfad C:\Programme\boost\boost_1_36_0\boost\ ein. Dann wählst du den Eintrag Library files und trägst dort den Pfad C:\Programme\boost\boost_1_36_0\lib\ ein. Das wär auch schon alles 😉



  • also ein Programm, in dem ich boost verwende, wird jetzt ohne Probleme erstellt! aber wenn ich es jetzt ausführen will geht das nicht und es erscheint folgende Fehlermeldung: (also nicht in der konsole, die wird gar nicht geöffnet, sonder es erscheint ein extra fenster!!!)

    <zuerst kommt der Pfad des Programs>
    Diese Anwendung konnte nicht gestartet werden, weil die Anwendungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.

    Ich gehe davon aus das es i-wie am Boost liegt, weil wenn ich ein anderes Program erstelle ohne boost kann ich das ohne weiteres ausführen!

    Weis jmd an was das liegen kann?



  • ich verstehe immer noch nicht, wieso man sich das boost-paket bei problemen nicht gleich selbst erstellt...
    letztlich muss man lediglich die sourcen saugen und unter windows bjam mit einigen parametern starten. insbesondere, da die online verfügbaren libs meist nur für 32 bit compiler zur verfügung stehen!

    ansonsten muss man unter windows nicht viel machen...

    daher mein tipp:
    - boost sourcen saugen
    - bjam saugen (und in den boost ordner kopieren)

    und in der kommandozeile mittel

    bjam --build-dir="c:/boost" --toolset=msvc-8.0 architecture=x86 address-model=32 install --build-type=complete
    

    die librarys kompilieren (address-model=64 für 64 bit architekturen!)
    weitere optionen findest du hier:
    http://www.boost.org/doc/libs/1_37_0/more/getting_started/windows.html

    die zu linkenden libs musst du unter windows nicht angeben, da die benötigten beim kompilieren automatisch ermittelt werden. mit der präprozessordirektive BOOST_LIB_DIAGNOSTIC werden dir diese aber angezeigt.


Log in to reply