Build-essential Problem



  • Guten Tag zusammen,

    Ich hab ein Problem, wenn ich

    apt-get install build-essential
    

    ausführen will kommt eine Fehlermeldung..

    E: Konnte Lock /var/lib/dpkg/lock nicht bekommen - open (11 Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    

    Was kann ich hier machen??

    mfg 08mmarte



  • Alle anderen Prozesse beenden, Debian-Pakete installieren oder deinstallieren.



  • Kann es sein, dass irgendwo adept oder sowas läuft? Die apt-GUIs locken normalerweise auch.



  • Dieser Thread wurde von Moderator/in nman aus dem Forum Linux/Unix in das Forum Themen rund um den PC verschoben.

    Im Zweifelsfall bitte auch folgende Hinweise beachten:
    C/C++ Forum :: FAQ - Sonstiges :: Wohin mit meiner Frage?

    Dieses Posting wurde automatisch erzeugt.



  • Werde mal alle Prozesse beenden...

    Danke

    EDIT: Wie geht das am besten??



  • 08mmarte schrieb:

    Werde mal alle Prozesse beenden...

    Danke

    EDIT: Wie geht das am besten??

    sudo kill -9 -1



  • Hat dein Nutzer-Account die notwendigen Rechte um diese(s) Paket(e) zu installieren? Versuche es doch mal als root.



  • @Der nette Helfer: Irgendwie habe ich das Gefühl, wenn ich alle Proesse "kille" werde ich nicht mehr allzu viel tun können...:)
    EDIT: Tatsächlich....Ubuntu ist abgestürzt...(Bildschrim war voll mit violetten Strichen...)

    @Herrmann: Sorry hab den Befehl zu oberst falsch geschrieben....

    sudo apt-get install build-essential
    

    wäre richtig...



  • 08mmarte schrieb:

    @Der nette Helfer: Irgendwie habe ich das Gefühl, wenn ich alle Proesse "kille" werde ich nicht mehr allzu viel tun können...:)
    EDIT: Tatsächlich....Ubuntu ist abgestürzt...(Bildschrim war voll mit violetten Strichen...)

    @Herrmann: Sorry hab den Befehl zu oberst falsch geschrieben....

    sudo apt-get install build-essential
    

    wäre richtig...

    Ja, das war mir schon bewusst. Ich habe dir nur deine Frage beantwortet 😉

    Aber nach dem Reboot hast du jetzt keine Probleme mehr mit apt-get, richtig?



  • 08mmarte schrieb:

    @Der nette Helfer: Irgendwie habe ich das Gefühl, wenn ich alle Proesse "kille" werde ich nicht mehr allzu viel tun können...:)
    EDIT: Tatsächlich....Ubuntu ist abgestürzt...(Bildschrim war voll mit violetten Strichen...)

    Ich hoffe, du hast jetzt gelernt, dass du niemals blind irgendwelche Befehle ausführen solltest, wenn du nicht weißt, was sie bewirken. Das gilt besonders, wenn dem Befehl ein "sudo" voransteht 😉



  • Es kam mir sowieso komisch vor....der Befehl hat doch "nur" den Prozess 1 und 9 beendet richtig??

    EDIT: @Der nette Helfer: Tatsächlich, jetzt funktionierts danke...



  • 08mmarte schrieb:

    Es kam mir sowieso komisch vor....der Befehl hat doch "nur" den Prozess 1 und 9 beendet richtig??

    Nein, der killt so ziemlich alle Prozesse, die man killen kann. Und als Root sind das ganz schön viele.

    (-1 steht für "alles außer init und kill" und -9 steht für SIGKILL, also "sofort unwiderruflich und unblockierbar killen".)



  • Aha...
    Danke für die Info..



  • Ist übrigens ein Beispiel aus man kill:

    man kill schrieb:

    EXAMPLES
    kill -9 -1
    Kill all processes you can kill.

    Und die (richtige) Antwort auf deine Frage

    08mmarte schrieb:

    Werde mal alle Prozesse beenden...

    Danke

    EDIT: Wie geht das am besten??

    😃 😉


Log in to reply