probleme beim compilieren



  • hi
    mein problem ist das ich beim compilieren diese fehlermeldung bekommen:

    1>------ Erstellen gestartet: Projekt: 10_1, Konfiguration: Debug Win32 ------
    1>Kompilieren...
    1>Listing_10_1.cpp
    1>Manifest in Ressourcen wird kompiliert...
    1>Verknüpfen...
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__DispatchMessageA@4" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__TranslateMessage@4" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__GetMessageA@16" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__CreateWindowExA@48" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__RegisterClassExA@4" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__LoadCursorA@8" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__LoadIconA@8" in Funktion "_WinMain@16".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__DefWindowProcA@16" in Funktion ""long __stdcall WindowProc(struct HWND__ *,unsigned int,unsigned int,long)" (?WindowProc@@YGJPAUHWND__@@IIJ@Z)".
    1>Listing_10_1.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol "__imp__PostQuitMessage@4" in Funktion ""long __stdcall WindowProc(struct HWND__ *,unsigned int,unsigned int,long)" (?WindowProc@@YGJPAUHWND__@@IIJ@Z)".
    1>.\Debug/10_1.exe : fatal error LNK1120: 9 nicht aufgelöste externe Verweise.
    1>Das Buildprotokoll wurde unter "file://c:\Dokumente und Einstellungen\Christian\Eigene Dateien\Visual Studio 2005\Projects\10_1\Debug\BuildLog.htm" gespeichert.
    1>10_1 - 10 Fehler, 0 Warnung(en)
    ========== Erstellen: 0 erfolgreich, Fehler bei 1, 0 aktuell, 0 übersprungen ==========
    

    ich benutzte visual c++ 2005 und habe die platforum sdk installiert.
    ich hoffe ihr könnt mir helfen.



  • dein compiler scheint die *.lib dateien nicht zu finden.



  • aber welche fehlt?



  • Das steht in der Doku der benutzten Funktion, welche Lib du einbinden mußt. Schau doch einfach selber in der MSDN nach... so schwer ist das ja nicht.


Log in to reply