[MS Visual Studio 2008] Debugging nicht mehr möglich



  • Hallo Community,

    nachdem ich während eines Debugging-Vorgangs versehentlich die Enter-Taste gedrückt habe, lässt sich das Projekt nun nicht mehr debuggen.

    Die zugehörige Meldung lautet:

    Für "... .exe" können keine Debuginformationen gefunden werden oder sie stimmen nicht überein. Symbole nicht geladen.
    *

    Ich kann das Projekt zwar trotzdem debuggen, allerdings kann Visual Studio ohne Symbole keine Breakpoints setzen, was das Debuggen wiederum unmöglich macht.

    Ich habe leider keine Idee, wie ich diesen Fehler beheben soll. Für Tipps und Anregungen bin ich sehr dankbar.

    Freundliche Grüße,

    Jas



  • Hast Du im ConfigurationManager unter Build auf Debug umgestellt?

    Unter unter Project->Properties die Konfiguration Debug auswählen, dann im Baum: ConfigurationProperties->C/C++ -> General->DebugInformationFormat auf Program Databse for Edit&Continue stellen.

    Ich habe nur das Englische Visual Studio, wird aber denke ich ähnlich sein.



  • Hallo Affenschande,

    danke für Deine Tipps, leider haben sie das Problem nicht beseitigt.



  • Also Du hast beide Einstellungen vorgenommen? Den Kompilevorgang auf Debug gestellt und dafür gesorgt das die Debuginformationen bei Debug auch erstellt werden? Oder hast Du die Einstellungen nicht gefunden?

    Weißt Du noch was Du verändert hast? Wo Du aus versehen mal Enter gedrückt hast? In einem Einstellungsmenu, oder bei irgendeinem Nachfragedialog der aufgepoppt ist?



  • Hallo Affenschande,

    genau genommen war es folgendermaßen:

    Nachdem das Programm auf einen Breakpoint gelaufen war habe ich mittels Einzelschritt-Funktion das Debugging schrittweise fort geführt. Nach einigen Einzelschritten habe ich dann versehentlich die Enter-Taste gedrückt. Daraufhin wurde an der Stelle im Code eine Leerzeile eingefügt. Das erzeugte ungefähr folgende Meldung:
    *
    Die Datei xy.cpp stimmt nicht mehr mit der ursprünglichen Datei xy überein...
    *
    An dieser Stelle bin ich nicht sicher welche Optionen für die Quittierung dieser Meldung angeboten wurden, jedenfalls wollte ich anschließend das Debugging abbrechen, über die entsprechende Menüfunktion. Das war aber nicht möglich. Also habe ich den Taskmanager bemüht und gesehen das die Anwendung die ich debuggte nicht mehr reagierte, deshalb beendete ich sie über den Taskmanager. Visual Studio gab anschließend auch einige Fehlermeldungen aus, beendete sich aber nicht.
    Der nächste Debugging versuch endete dann in der Fehlermeldung aus meinem ersten Post.

    Dies nur der Vollständigkeit halber. Als ich gerade eben einfach Visual Studio neu gestartet habe funktionierte wieder alles.

    Vielen Dank für Deine Mühen, Affenschande.

    Freundliche Grüße,

    Jas



  • Hatte heute das gleiche Problem, nach Neustart von Visual Studio 2008 funktioniert das Debugging nun wieder.

    Ich hatte über Nacht den Rechner mit allen Programmen laufen lassen (größeres Programm währenddessen kompilieren lassen), am nächsten Tag hatte ich dann die geschilderte Problematik.

    Projektmappe bereinigen etc. hat alles nichts gebracht.


Log in to reply